Nissan Titan Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter · #1 ·
Hey Guys

I just got my mini lift to my house and had a question. The PRG mini lift I got was the 2" front and 1.5" rear. When I measure the front spacers there measuring only 1.25". Is this what they all come. How does it lift the front "2 inches" is the spacer it self is only 1.25.

I wanted to put it in tomorrow so if anyone can give me some feedback I would really appreciate it.

Thanks
Troy
 

·
Premium Member
Joined
·
4,162 Posts
Its just the way the suspension works. They are the right size so happy lifting !
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #4 ·
Mines an 04. Shes an oldey but a goody
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #6 ·
So I just finished putting in the mini lift and it looks great. I love the way the front end sits now and I put the 1.5inch in the rear so it still has a little bit of a rake for when I throw the boat on the back or put the sled or quad in the box. Everything went fairly smooth, the instructions were bang on, the only thing I will add is that if you live anywhere that gets lots of snow, and the roads have lots of salt on them leading to rust, make sure you have some kind of penetrating spray/lube to put on the nuts and bolt before taking them off.

The one question I have now is that when I was driving home I noticed that the stearing is harder to turn all the way over. When im turning sharply I can actually feel the truck slow right down. I dont hear anything rubbing, scratching or anything like that. It was dark when I came home so Ill have to check tomorrow to see if there is anything rubbing on the tires. I followed the instructions very carefully so im not sure what is going on. I havnt gotten the wheel allignment or toe adjustment yet so maybe that is causing this problem.

If anyone has any ideas let me know.
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #7 ·
Ok so I drove to work today and when driving in the parking lot with the windows down I think I figured out what is going on. It seems like the back tires (the Lt one at least for sure) is locking up and dragging when im going slow, especially I notice it when turing corners slow. What I was thinking is that when I put on the E-brake when I did the front spacers the brake did not let go completly. Is there a way to back it off of loosen the e-brake.

Im just spit ballin here and trying to figure out whats going on. Please let me know if you have any suggestions.
 

·
Registered
Joined
·
984 Posts
That's pretty strange. Did you get your alignment done yet?

Notice any rear axle leaks?
 
1 - 9 of 9 Posts
Top