Nissan Titan Forum banner

1 - 20 of 42 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
Hi everyone,
So this past weekend I put the 2' front 1' rear PRG leveling kit on my 2004 KC. It looks awesome, but, like many others, I now have the clunky, rattling, annoying sound coming from my front end. I have searched many many threads about this and I have retightened everything so I'm positive that nothing is loose. I had my alignment done and the mechanic said everything looked good and there were no bad parts that he could see. My only solution that I can think of is that I may have bad shocks. My T has about 70,000 miles on it and the stock Rancho's are still on it. I ground down the lip on the coil bucket because there was some UCA contact with it, but still there was sound. From reading these forums, i'm leaning towards the problem being with my shocks. Im super frustrated and can not find anything that would be rattling/clunking. I can even feel it in the floor boards under my feet. Any suggestions on replacement shocks and where I can find them? Any ideas on other reasons why this noise would be caused?
 

·
Registered
Joined
·
620 Posts
A lot of people go with the Bilstein 5100's or Bilstein HD's. The 5100's will add .5" when they are set at 0 so I probably wouldn't get these since you are already getting coil bucket contact. The HD's the basically the same length as the stock shocks so they are probably your best bet. Check out shockwarehouse.
 

·
Registered
Joined
·
41 Posts
Discussion Starter #3
A lot of people go with the Bilstein 5100's or Bilstein HD's. The 5100's will add .5" when they are set at 0 so I probably wouldn't get these since you are already getting coil bucket contact. The HD's the basically the same length as the stock shocks so they are probably your best bet. Check out shockwarehouse.
thanks, any other ideas (other than shocks) about where this noise is coming from?
 

·
Registered
Joined
·
2,028 Posts
swaybar end links?
 

·
Registered
Joined
·
94 Posts
yea, sway bar end links, thats what my problem was, so i just took off the sway bar. No more noise!
 

·
Registered
Joined
·
14,135 Posts
x3 on sway bar end links. make sure they are tight. I didnt tighten mine and they clunked and i could feel it in the floor boards.
 

·
Registered
Joined
·
41 Posts
Discussion Starter #7
x3 on sway bar end links. make sure they are tight. I didnt tighten mine and they clunked and i could feel it in the floor boards.
I tightened those S.O.B.'s as tight as i could go because I read on here that they might be causing the clunking. Maybe they are bad?? seriously though, I did those with a breaker bar and im pretty positive they are tight enough! Any thoughts?
 

·
Registered
Joined
·
5,748 Posts
I'm leaning more towards coil bucket contact. That's how mine felt when I had the stillen kit on my old T.
 

·
Registered
Joined
·
41 Posts
Discussion Starter #9
I'm leaning more towards coil bucket contact. That's how mine felt when I had the stillen kit on my old T.
I already grinded it down though... Was your UCA hitting the coil bucket anywhere but the lip of the coil bucket? I could see where mine was hitting and i ground a tab out of it and i thought that would be good. The problem is, is that I can feel it and hear it over small bumps in the road, not just pot holes... This has me stumped
 

·
Registered
Joined
·
94 Posts
Try going with prg's endlinks, or take off the sway bar and see if the noise stops, if it does, you just found ur problem, if not, continue troubleshooting
 

·
Registered
Joined
·
41 Posts
Discussion Starter #11
I can try taking off the sway bar. Do i need to take anything else off to get them off? I dont remember if I had to take anything else off prior to removing them
 

·
Registered
Joined
·
14,135 Posts
Hmm. you said you tightened them down, so i doubt its your sway bar, your pm asked for a pic so here is a pic of the general area of what i'm talking about. I'd suggest taking the bar off and seeing if it helps. Also you grinded the bucket down, but now you cant tell if its still tapping the bucket, so maybe hit it with spray paint and the next day check to see if it is chipped anywhere.
 

Attachments

·
Registered
Joined
·
94 Posts
Not that I recall, but I would jack up the front tires a little bit to relieve some tension, makes it easier.
 

·
Registered
Joined
·
94 Posts
I'm almost positive it's those crappy end links, when I put my leveling kit they creaked, groaned, popped all the time.
 

·
Registered
Joined
·
1,266 Posts
Make sure the Lower Control Arm adjuster bolt/nuts are stupid tight. Tightened mine up with a breaker bar and cheater and my noise disapeared. Felt like the nosie was gonna come thru my floorboard before i tightened 'em. Just a thought...........................
 

·
Registered
Joined
·
14,135 Posts
wait you lifted the truck but didnt put end link extensions on? I'm pretty dang sure archer is correct.
 

·
Registered
Joined
·
94 Posts
I just took off my sway bar, then I had no noise
 

·
Registered
Joined
·
94 Posts
Just took off my sway bar, no more noise, problem solved
 

·
Registered
Joined
·
94 Posts
Sorry for the 2 posts, my iPhone is messin up
 
1 - 20 of 42 Posts
Top