Nissan Titan Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
For perhaps 30K miles I have had a recurring intermittent problem with the ABS engaging (2004 Titan 4 WD) when not required. The typical situation is that I will be driving along and will apply the brakes and the ABS will engage (pedal goes down farther than usual and grinding noise is emanated – the brake light on the dash also illuminates). This happens on dry pavement – in no way is the engagement induced by road conditions. The condition persists until I turn off the vehicle and then restart it. I can then often drive the vehicle for 3 months before it happens again. Sometimes it will happen several times within a week.
I have taken it to the dealer. First they said they had a service bulletin and reprogrammed my chip. Problem not solved. I managed to get it in while the condition was happening. They confirmed it was a problem with the ABS – da -nothing more. Apparently the computer readout is not helping to diagnose the problem. Current thinking is it is one of the sensors – but they do not know which one. They want me to bring it back again when the problem is occurring.
Anybody have any thoughts on my problem?
 

·
Registered
Joined
·
29 Posts
I had this exact same problem when i first bout my '04 Titan in '08. When i was driving down the road, i'd press the brake and the brake light would come on and the pedal would pulsate to the floor and the front tires would lock up (abs engaging). Cut the truck off as u did and it goes away for awhile. Same exact issue. I took mine to a Nissan dealer and they reprogrammed the abs and it fixed it for two weeks before it did it again. Then they kept it for two weeks until they diagnosed it as the ABS Control Module and so they replaced that ($1400). Got the truck back and a week later it did the same thing. Well i took it back and then they diagnosed it as a brake booster. So they replaced that, after a two week backorder, and i haven't had a problem since. In my experience, it is going to be the brake booster on the truck. How or why i do not know but that's what they replaced on mine after about a month and a half of being without the truck.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Thank you for the feedback. It sounds exactly the same. Did they ever suggest that it was the sensors that run to each of the wheeles? The Nissan dealer seems pretty clueless about the problem.

How much was the brake booster repair? I don't even know where to look for the brake booster but will google the part to get some idea of what it is.
 

·
Registered
Joined
·
29 Posts
The dealer never said anything about the abs sensors being an issue but that's just of what i remember. It took them a total of 2 months to figure the problem out and repair it. The dealer had my truck for a total of those 7 wks. I had it the one week after i got it back from the reprogamming. Needless to say i was paying for something i couldn't drive. This was right after i bought my truck and i had purchased an extended warranty so the warranty paid for it all. I paid for the reprogramming, which was suggested by the dealer to fix the issue, and when it didn't fix it and i brought it back, they tried to tell me i was going to have to pay the deductible for the warranty work. :bangit: Not quite. I made my feelings known about that and they paid for it since it was their issue, not mine. If i'm not mistaken, the brake booster from Nissan is around $800 or so so if you have an extended warranty at all, call them up. The booster itself is mounted on the firewall of the truck usually on the drivers side.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
Thank you. I found the part on line. $216 for new. Used/refurbished?? about half that. The diagram from Dealerdirectparts.com is unclear on location. Time to find a local mechanic.
 

·
Registered
Joined
·
134 Posts
I know this is an old post, but I'm having the same issue, wondering if this fixed the problem, and how easy it is to fix. Thanks
 

·
Registered
Joined
·
133 Posts
So i hope im not to late offer my suggetsions? I believe what you are experiencing is the c1179 code delta s sensor... Theres a bulletin for this all you gotta do is reprogrm the abs module. EXCepT if ur module is uptodate then most likely you will have to replace it ps there different types of abs/vdc modules make sure its the right one. The bulletin clearly states pedal goes down with abs activating and brake light or abs light coming on accompanied by a c1179 delta s code... I had the same problem with my truck 04 T. went to work scanned it found the code performed the reprogram and havent had a problem since.. Unfortuantly the dealer may not do this untill the. code is present. due to the safety issues with a missdiag. Any other thoughts let me know.u
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
The Nissan dealership tried the reprogramming approach - it did not work. I took it to the dealer when the problem was happening - still could not get it fixed. They wanted to replace the entire ABS at my expense. with the other problems I was having (two cracked headers, a squeek that could not be issolated, and others) I traded for a new Ford f150. Hope you have better luck thatn me. I was very dissapointed with Nissan service and will not by another vehicle from them.
 

·
Registered
Joined
·
133 Posts
sorry to hear that it didnt work if it was my dealership i would have bent over backwards to help a fellow T owner out i guess i would need the details but ya sorry to hear that
 
1 - 9 of 9 Posts
Top