Nissan Titan Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter · #1 ·
has anyone had a problem installing a procomp lift can you list them right now my dealership is having a problem installing my procomp lift becuase of the right rear cam disk bolt? has anyone experienced this? and is the kit suppose to come with front brake lines? 4wheelparts said no, the instructions say yes?
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #3 ·
PrerunnerGreg said:
The kit comes with brake lines. Dont let them bs you about that. as far as the cam bolts, what problems are they having?
i think they said that the right rear was hitting something i will give a better description tomarrow morning when they reopen. they said they cannot adjust realignment becuase of it.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #4 ·
i guess it's also missing a lower camber adjuster bolt. so now i'm waiting for to parts while i'm out a truck. the dealer sells the fabtech but after reading all the info on here i wanted the procomp so later i could add the SAWS from PRG. Procomp needs better quality control to make sure that the parts are in the box.
 

·
Registered
Joined
·
6,067 Posts
fastcrazyhurt said:
i guess it's also missing a lower camber adjuster bolt. so now i'm waiting for to parts while i'm out a truck. the dealer sells the fabtech but after reading all the info on here i wanted the procomp so later i could add the SAWS from PRG. Procomp needs better quality control to make sure that the parts are in the box.

You're supposed to just re-use the factory lower control arm bolts. So if that's missing, then your dealer is the one who lost it!

Also, you can add the SAW's to the Fabtech kit.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #6 ·
the dealer said that the right rear doesnt' work that it hit the cam disk or something so they tried a fabtech one and it did work. maybe its just the wrong bolt they sent with my kit. i know that the fabtech works with saws also but i heard better reports on here about the procomp lift.
 

·
Registered
Joined
·
6,067 Posts
fastcrazyhurt said:
the dealer said that the right rear doesnt' work that it hit the cam disk or something so they tried a fabtech one and it did work. maybe its just the wrong bolt they sent with my kit. i know that the fabtech works with saws also but i heard better reports on here about the procomp lift.

Yeah, the oversized 'head' of the cam bolt probably wouldn't fit between the 'tabs' on the ProComp drop bracket. I had that issue with mine, had to grind off some of the powdercoating so that it would fit.



NM about the SAWS, I misinterpreted what you had typed.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #8 ·
ya thats the same problem but 3 of the four worked. so i have to get 1 more of each part # 90-3245 and 90-3246 and the brake line kit. now i have to wait who know how long to get the parts from procomp since 4wheelparts has to order them from them meanwhile i'm out of my only rig. since its on the rack almost done in the shop
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #9 ·
wish i would of waited for prg to open after the holidays now i'm sure they would have tooken better care of me. but i wanted to get it ordered and 4wheelparts was open xmas eve.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top