Nissan Titan Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
249 Posts
Discussion Starter #1
Hey guys...I've got a couple new problems that I need some help with.

I just received my first actual tune (not the base tune, the first one after sending them my first logs) from UpRev (Osiris) and in the email, Jared said that my fuel compensation is all over the place. He said that it's probably due to some sort of air leak *after* the MAF, but I just tore into it all - and not only was everything tight, I couldn't find a thing wrong.

I installed the Volant CAI and 2" Helix TBS (along with doing the TB coolant bypass) right after I got the truck back in Jan '07...I've taken off the Volant filter and recharged it every 4K or so (live in a dusty high-desert climate, so it does get dirty) - but other than that, I've not messed with anything else.

After checking that everything was indeed tight and then taking it all apart and putting it back together again, I'm really curious as to how Cipher could be reading my fuel compensation and what could lead to this. Like I said, I *just* took it all apart (including the Helix TBS) and put it back together again, and I *know* that it's all snugged up just the way it's supposed to be.

Here's the logs from Jared's email that he sent with my first 'actual' tune:

----------------------begin c/p from email------------------------
Code:
Your updated ROM is attached.

The notes about the adjustments made are listed below.

11/13/2008 eTune A

Got logs > a month ago, but data kept getting lost in email forwards.

MAP 1:

Running lean on the high end.

AFR averages: Adjustment to fuel compensation

2800 : 12.451    Good

3200 : 14.717    +16

3600 : 13.7175   +7

4000 : 13.8502   +8

4400 : 13.8986   +8

4800 : 14.3677   +11

5200 : 14.3777   +11

Up to : 5675 : 14.2494   +10

MAP 3:

Getting beter ignition advance on map 3. Going to copy higher RPM values into map 1.

Also running lean.

AFR averages: Adjustment to fuel compensation

1200 : 14.47      +11

1600 : 12.465    good

2000 : 12.445    good

2400 : 12.22      -2

2800 : 13.4719   +5

3200 : 14.495    +11

3600 : 13.74      +5

4000 : 13.8248   +5

4400 : 13.9478   +6

4800 : 14.3933   +11

5200 : 14.41      +11

Up to : 5588 : 14.2564   +10

 

All in all, the fuel compensation tables ended up very choppy.

I'm wondering if there is an inteke leak that is causing unstable MAF readings.

Later,

Jared Ainsworth
----------------------begin c/p from email------------------------

So, I've got map 1 as 'Performance', map 2 is blank (couldn't think of anything else I wanted), map 3 is 'Towing', map 4 is 'Regular Gas mode' (for when I go to Vegas which is about 2.5 hours south) and map 5 is 'Valet'.

After checking that everything is as it should be (no leaks that could be discovered) - I went ahead and flashed the new ROM...everything went fine - but I did notice that the timing was backed down to 14...that's not normal is it? I had the 2* advance done right after I bought the truck and haven't had anything but Osiris near my computer. If it's not right, I can change it, but I'd need to read a bit more on how first.

Anyway, any suggestions or insight on something that I've perhaps missed would be appreciated!

Something that we used to do in the old days of carburetors, is to spray WD40 around the seals while it's running to see if the engine dies - if it dies, there's an air or vacuum leak - if it doesn't, there's not...so does that still apply? Could I spray WD40 around the TBS and the rubber Volant grommets (except before the MAF) to see if there's a leak somewhere?? I need some input on this before I can move on.

Thanks for any input you guys have for me!!

Psychlone
 

·
Premium Member
Joined
·
2,005 Posts
Isn't WD40 flammable? I wouldn't do it, just my opinion. Aside from that I have nothing to offer if you've already tighten everything up.


PS- Did you looks closely for cracks or anything in the intake and everything?
 

·
Registered
Joined
·
249 Posts
Discussion Starter #3
Yeah...WD is indeed flammable, but it will kill the engine (of a carburetor engine) if there's any vacuum or air leaks whatsoever...this is an old-school trick that I learned probably 25 years ago.

But, like I said, I've torn the entire CAI out, put it back together and tightened everything up to just how it's supposed to be. And, I inspected all the rubber, the molded tube, the TBS, the TB and the gaskets between them - and there's not a hint of anywhere it could possibly leak...then I tightened it all back up to the point that the hose clamps are at the edge of stripping and the TB/TBS are tight enough that if I turn it another quarter, it'll crack one or both of them (or strip those brass bolts)

I'm at a loss here...

Psychlone
 

·
Premium Member
Joined
·
20,599 Posts
Is it possible that it is an electrical problem instead? BTW, good hearing from you. Where you been?
 

·
Registered
Joined
·
249 Posts
Discussion Starter #5
Not that I'm aware of - nothing has changed on my vehicle since I did all those initial mods last year...with the exception of Osiris' base tune in September. And, I've not experienced anything that would lead me to believe that there's some sort of electrical issue - I did have the truck in at the dealership a while back for rear shocks, but they said nothing after diagnostics, so I doubt highly that's the case.

As for what I've been up to, I own a huge 'mom-and-pop' restaurant in my hometown, and I've been busy as Hell with it - well, as busy as can be expected in this economy! ;) You?? (well, I realize that you're still here, I just haven't caught up with anyone for quite some time.)

Psychlone
 

·
Premium Member
Joined
·
20,599 Posts
The only reason I mention electrical is that once you've ruled out everything mechanical, what's left?
 
  • Like
Reactions: Psychlone

·
Registered
Joined
·
249 Posts
Discussion Starter #7
True. I'm pretty decent at troubleshooting, and if I can't put my finger on it via mechanically, then I'll turn to that.

Just out of curiousity, do you, or anyone, know what I should be looking for in Cipher to check this 'fuel compensation'?? I'm just not familiar enough with Cipher to even know what to look for... Any ideas?

Psychlone
 

·
Premium Member
Joined
·
20,599 Posts
Just out of curiousity, do you, or anyone, know what I should be looking for in Cipher to check this 'fuel compensation'?? I'm just not familiar enough with Cipher to even know what to look for... Any ideas?

Psychlone
Can't help you there. Osiris is still on my wish list. :)
 
1 - 9 of 9 Posts
Top