Nissan Titan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2005 SE and my rear power window is not working anymore. The switch doesn't do anything and I have no clue if there is a fuse for it? Or is it something more difficult to figure out? Anyone have any troubleshooting advice for me?
 

·
Registered
Joined
·
2,942 Posts

·
Registered
Joined
·
1 Posts
I have a 2005 SE and my rear power window is not working anymore. The switch doesn't do anything and I have no clue if there is a fuse for it? Or is it something more difficult to figure out? Anyone have any troubleshooting advice for me?
I have a 2006 Titan CC SE, and I had the same problem. This is my first post, and after finding so much info in here about my truck and mods, I decided to sign up and contribute.

My rear window suddenly stopped working after adding LED lights and messing with dash and stereo. I ended up finding out that most power windows have a push button reset. I will post pictures to use as a guide. But for the rear bed large sliding window, here was my trouble shooting process.
1. Removed dash and checked for power with my meter at the switch. All ok.
2. Dropped back rests of rear seats and popped the plastic tabs holding the fabric and middle seat belt to the back of the cab.
3. pulled fabric away and found window regulator and connection, check for power there. All ok
4) Found a small black rubber button, pressed it. No click, no definitive "click" but.... WINDOW WORKED!

I ended up cutting a slit in that carpet before re-attaching the plastic fasteners so if that BS ever happens again I would have easy access.
 

Attachments

·
Registered
Joined
·
1 Posts
I have a 2006 Titan CC SE, and I had the same problem. This is my first post, and after finding so much info in here about my truck and mods, I decided to sign up and contribute.

My rear window suddenly stopped working after adding LED lights and messing with dash and stereo. I ended up finding out that most power windows have a push button reset. I will post pictures to use as a guide. But for the rear bed large sliding window, here was my trouble shooting process.
1. Removed dash and checked for power with my meter at the switch. All ok.
2. Dropped back rests of rear seats and popped the plastic tabs holding the fabric and middle seat belt to the back of the cab.
3. pulled fabric away and found window regulator and connection, check for power there. All ok
4) Found a small black rubber button, pressed it. No click, no definitive "click" but.... WINDOW WORKED!

I ended up cutting a slit in that carpet before re-attaching the plastic fasteners so if that BS ever happens again I would have easy access.
I've been searching all over about my window not working. And then I come across this post. I'm gonna have to try this.
 
1 - 4 of 4 Posts
Top