Nissan Titan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi All,

Been a long time visitor and reader, not much of a poster, but wanted to register so I could ask about this... I've searched but not come up with any answers, so I am either using the wrong terminology, or just going blind :nerd:

The rear power port, the one near the vents on the back of the center console, has no power. I am assuming this is fuse related since I recently found out one of the 20v fuses for the front passenger port was missing, causing the other to blow regularly... (previous owner was a company, so who knows what they did.) But for the life of me, I cannot locate where the fuse should be for the rear seat one.

I've found the fuse locations for everything but this. Can anyone point me in the right direction?

Thanks in advance!
 

·
Registered
Joined
·
2,942 Posts
Maybe location 6 in the fuse block next to the glove box?

Power port (aka cigarette lighter, cell phone charger)
Driver side #18 - fuse block
Passenger side #7 -fuse block
Center console #6 - fuse block
Bed #28 - fuse and fusible link box

I don't have one since I'm a King Cab so I can't check.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I'll double check that... I thought I had 20s in both 6 and 7, but maybe I am mistaken. Thanks!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Maybe location 6 in the fuse block next to the glove box?

Power port (aka cigarette lighter, cell phone charger)
Driver side #18 - fuse block
Passenger side #7 -fuse block
Center console #6 - fuse block
Bed #28 - fuse and fusible link box

I don't have one since I'm a King Cab so I can't check.
Thanks for the tip, but all those are good... still no go on that rear seat power port. I'll keep poking around. Thanks though!
 

·
Premium Member
Joined
·
141,094 Posts
Move some fuses around. They may not actually be good. They just look like they are.
If that doesn't do it, you are going to need a test light.
 
1 - 5 of 5 Posts
Top