Nissan Titan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
After about 6 trips to the local dealer and a new set of rear leaf springs (Lft & Rt Rear) my Titan still makes a metallic "Slapping" sound. This last visit the service manager explained to me that they were simply out of options and had no solution! I couldn't believe it! They worked with the Nissan engineers and were frankly out of ideas. I assume Nissan just under engineered the suspension.

I pull a heavy boat, but still well within the manufactures towing capacity. Is there any one out there that has had this problem? I know there was a bracket solution for a squeaking noise generarted from the springs - they did that repair to mine - but it did not stop the slapping noise. I usually hear it at low speeds in my neighborhood when I drive over small bumps on the road. It sounds like an old beat up truck!
 

·
Registered
Joined
·
18 Posts
I have the same exact thing on my 06, you described it perfectly. I was at the dealer for the ecu relay recall, had them check out the noise and they wanted to use a tool to listen and tried to charge me a hundred bucks for it. They said it may be a cracked leaf. You changed yours and still had it,so what the heck is it then???:teethmast:confused:
 

·
Registered
Joined
·
28 Posts
I also have the same issue. It is a loud metal on metal noise only when I go over smaller/medium size bumps like a manhole cover or small potholes. I took mine to the dealer yesterday and they did not find anything. I have been digging around on the web and saw some people reccommend changing the leaf spring shackles. Anyone find this to fix the problem or anything else?
 

·
Registered
Joined
·
1 Posts
I have the same problem in my 2007 Titan LE. I'm fairly certain that it is only on the driver's side. The noise sounds like two pieces of flat metal smacking together. The noise is very quick it doesn't really resonate afterwards which makes me think its something under tension and my gut was telling me it was something to do with the leaf spring. Going to be ordering the heavier shackles very soon - hopefully this solves the problem. Nothing like driving a nice truck that sounds like it's falling apart every time I hit a little bump. I had my truck to multiple shops, including two Nissan dealerships and they both told me they thought it was my exhaust hitting something. Wrong.

If anyone knows anybody that has solved this problem I'd LOVE to hear the solution.
 
1 - 6 of 6 Posts
Top