Nissan Titan Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hoping this exists and someone has done it. Bought a Kenwood DDNX9705S head unit and all the accessories (ASWC-1, etc), but I'd like to be able to use the factory USB/Aux port and have it connect to my new head unit. Is there a USB adapter needed or harness for this to work? I don't want to put a cable in my glove box as I'd prefer a cleaner installation. Option 2 - Is there a USB extender that can fill in one of the blanks on the dash?

Vehicle is 2017 Titan SL w/ Rockford and Nav.

Option 3(?) - came across this from Scosche, but can't seem to find any reviews on this thing https://www.scosche.com/lnn10 - this would replace the ASWC-1, but I'm okay with that!
 

·
Registered
Joined
·
141 Posts
Hoping this exists and someone has done it. Bought a Kenwood DDNX9705S head unit and all the accessories (ASWC-1, etc), but I'd like to be able to use the factory USB/Aux port and have it connect to my new head unit. Is there a USB adapter needed or harness for this to work? I don't want to put a cable in my glove box as I'd prefer a cleaner installation. Option 2 - Is there a USB extender that can fill in one of the blanks on the dash?

Vehicle is 2017 Titan SL w/ Rockford and Nav.

Option 3(?) - came across this from Scosche, but can't seem to find any reviews on this thing https://www.scosche.com/lnn10 - this would replace the ASWC-1, but I'm okay with that!
check the connector at the back of the factory radio. inside the plug may be a mini usb-b connection. Which all you would need to get is a $5 adapter from somewhere (mini usb-b to usb-A). That's how it was in my 2016 frontier. My 12 Titan didn't have usb, so just bought a aux/usb add on.

should look like the end of this
[ame]https://www.amazon.com/AmazonBasics-USB-2-0-Cable-Male/dp/B00NH13S44/ref=asc_df_B00NH13S44/?tag=hyprod-20&linkCode=df0&hvadid=167126093426&hvpos=1o4&hvnetw=g&hvrand=10693936477771952807&hvpone=&hvptwo=&hvqmt=&hvdev=c&hvdvcmdl=&hvlocint=&hvlocphy=200517&hvtargid=pla-299575812713&psc=1[/ame]

then you'd just need this

https://www.ebay.com/itm/new-USB-2-0-A-Male-to-Mini-USB-B-5-Pin-Data-Cable-Female-Adapter-Converter-black/352115752428?_trkparms=aid=555018&algo=PL.SIM&ao=1&asc=58654&meid=9f46b813dbd74503ab7133aa9bb57fc3&pid=100008&rk=9&rkt=12&sd=282708444027&itm=352115752428&_trksid=p2047675.c100008.m2219
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3

Thanks

Found this image of the factory USB/Aux port - I can't find many images of rear of the factory head unit that details the USB connection; just that it shows the larger black connector. Maybe just a Mini USB B to USB A to connect to the new head unit?
 

·
Registered
Joined
·
71 Posts
This cord (or one like it) should do you fine for the USB.


It’ll plug into the USB out cord and into the factory USB.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
71 Posts
I don’t recognize that 4 pin connector for the aux port. Seeing the Nissan male side would tell you more than seeing the female side alone.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
71 Posts
A little research seems to indicate this is a common connection on Nissans. The Rogue cable that terminates in that connector is 24018-1VK0A. It’s a $70 harness, so I wouldn’t buy one just to cut it off, but knowing it’s common across a lot of models says a quick trip to the U-pull-It might reap rewards.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
Will find out tomorrow once the dash is opened up! I'll post an update for others interested.

Is factory mic able to also remain wired in? So much to think about with the radio swap these days! It was much simpler 15 years ago!



Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
Quick update: Mini USB B plugs directly into the factory USB port in the dash on 2017 Nissan Titan. Just used a Mini USB B to USB A to connect to the new Kenwood HU. So you CAN use the factory USB plug with aftermarket stereos.

Shop is having a hard time getting steering wheel controls, but will try during the work week when they can call support. They're saying the ASWC-1 isn't seeing the Titan. Will update on progress..

I chose the Kenwood DDX9705S. Pretty decent HU for the price since Kenwood just released the next models. Interface is fast and responsive. Not a very bright screen inside of our Titans due to the glare from the top. Same goes for the factory stereo. Maybe there's some kind of hood that can be installed to reduce the glare? The Kenwood should be plenty bright at night.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
15 Posts
Discussion Starter #9
Shop needs help with the steering wheel interface. Any suggestions? They say the ASWC-1 doesn't see the vehicle.. the whole point of swapping the radio was to retain the steering wheel controls.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
2,761 Posts
Make sure they're not using the crappy tapping connectors you get with the ASWC-1. I was trying to use those and it wouldn't find my vehicle, then I cut the wires and connected with butt connectors and it worked.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #12
The ASWC-1 worked fine on my Kenwood install....
Did you install it or have it installed? Anything special in terms of the wiring? It seems pretty straightforward and the ASWC-1 should program itself. The Kenwood did have pretty old firmware when it was installed, and I updated it after I got the truck back. Shop wants the truck during the week so they can call support.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
121 Posts
I had it installed at an indie shop, they didn't have any issues....hopefully your guys can get it squared away!
 

·
Registered
Joined
·
15 Posts
Discussion Starter #14
I had it installed at an indie shop, they didn't have any issues....hopefully your guys can get it squared away!
Assuming you have a second Gen Titan? The shop I took it to is pretty reputable with 20 years experience... I just have to take this on myself.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
15 Posts
Discussion Starter #16
Can anyone confirm if the blue and green wires connect to the ASWC - 1 pink and blue pink? Currently trying to use the blue and green in the middle of the factory connector for data from steering wheel controls for instructions from tech support.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
141 Posts
Can anyone confirm if the blue and green wires connect to the ASWC - 1 pink and blue pink? Currently trying to use the blue and green in the middle of the factory connector for data from steering wheel controls for instructions from tech support.

Sent from my Pixel 3 XL using Tapatalk
I would definitely stay away from doing colors on the Axxess instructions, stick to pin #s . I've found 9/10 times Axxess is wrong with the wire colors. And the ASWC-1 REALLY despises connections that are not direct, i.e. through a harness. I've only had luck with those directly spliced to the wires. Granted, that's MY OWN personal experiences.

That was on my Maxima, Murano, and Frontier........my Altima did pretty good with it.

For the Titan, i got the PAC SWI-RC and has worked like a dream from day one. Same install basically.
 

·
Registered
Joined
·
29 Posts
E
Can anyone confirm if the blue and green wires connect to the ASWC - 1 pink and blue pink? Currently trying to use the blue and green in the middle of the factory connector for data from steering wheel controls for instructions from tech support.

Sent from my Pixel 3 XL using Tapatalk
Ever get this working?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #19
E

Ever get this working?
There are two sets of 'Sky Blue' and 'Light Green' wires on the harness in my truck. The two on the end of the connector are the CAN +/-. (NOT the middle like instructions!) Also, a 68 OHM 1/4 watt resistor is needed AND the blue/grey from the ASWC-1 needs to remain ungrounded.

Couldn't map every button either. Hang up doesn't work, but I think everything else does. Not a huge deal!

Sent from my Pixel 3 XL using Tapatalk
 
1 - 19 of 19 Posts
Top