Nissan Titan Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
2010 CC stock 13k. Last Saturday stopped at a stop light and the engine starts to hesitate/miss. I pull out, and the T is running like crap. The SES light comes on and stays on. I call dealer the next day and drop it off. They replace a fuel injector which does not correct the problem (SES comes back on) and still running bad. Any ideas? It's been a week and I miss my T. After the front end recall fiasco and they had my truck for 2 weeks this is getting old.
 

·
Super Moderator
Joined
·
93,611 Posts
I would find a new dealer
 

·
Registered
Joined
·
433 Posts
did they tell you what the trouble code was?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
I asked, and they stated that it was a generic code. They somehow got it (code) to reflect a bad injector, but replacing #7 did not resolve the issue. I think next step is to replace the computer module (not sure of the exact name). There is another poster who was complaining about the lack of power (gurgling? I think the term he used) unless you kick it down. I was having the same issue. It wasn't like that when I first got the truck. It has power when you stomp on it, but not at certain speeds when going up hills. I love my truck but right now I'm not a happy camper.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5 (Edited)
Well my truck is still in the shop. They have replaced the #7 injector, and ECM and neither have resolved the issue. They were told to replace the entire wiring harness which will not arrive for several days. I will never buy another Nissan vehicle. This is beyond pathetic. I thought that the front end recall (2 weeks without truck) was a fiasco, this just takes the cake. Meanwhile I'm stuck driving their rental/loaner over the Christmas holiday which just pisses me off to no end. I'm calling Nissan Consumer Affairs in about 10 minutes. Am I the only one with this pathetic dealer service?:mad:

[Edit] Just got off the phone with Nissan Consumer Affairs and must say they are pretty much worthless. They wanted me to contact the dealer to get the part number for them to be able to track it down. I don't consider that to be my job. I lodged a formal complaint against the dealer which supposedly warrants a call from a regional rep. We will see.
 

·
Registered
Joined
·
115 Posts

·
Registered
Joined
·
51 Posts
Titan 17042<,
If you don't mind me asking, where are you located and what dealer are you going to? It seems to me any dealer you see nowadays you have to tell them whats wrong and what they need to fix: from my wife's Mercedes, my Nissan and even my last Dodge. It's pretty messed up but it's one of the things that makes this and other forums invaluable to me.
I am a factory trained Harley Tech and I have first hand experience of seeing good dealership/ service depts and bad.
I am sorry to hear about your experience and sincerely hope it remedies itself.
Depending on the situation you can try to lemon law it and maybe get a better deal somewhere with the new model year etc; just a thought.
Good luck, Tim
 

·
Registered
Joined
·
11 Posts
Discussion Starter #10
Titan 17042<,
If you don't mind me asking, where are you located and what dealer are you going to? It seems to me any dealer you see nowadays you have to tell them whats wrong and what they need to fix: from my wife's Mercedes, my Nissan and even my last Dodge. It's pretty messed up but it's one of the things that makes this and other forums invaluable to me.
I am a factory trained Harley Tech and I have first hand experience of seeing good dealership/ service depts and bad.
I am sorry to hear about your experience and sincerely hope it remedies itself.
Depending on the situation you can try to lemon law it and maybe get a better deal somewhere with the new model year etc; just a thought.
Good luck, Tim
I won't name the dealer outright, but if you look at my username the last 5 digits are my zipcode. A simple google search will provide the dealer name since there is only one Nissan dealer in my zipcode.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #11
I've now been informed that the wiring harness did not resolve the issue. There has been mention of replacing the head or entire engine since all electrical has been ruled out.

Am I asking too much if I refuse the new engine repair and ask for a brand new truck?

Information from the BBB website states the following: "The Lemon law provides relief if a new vehicle, within the first 18 months of ownership, has been subject to repair 3 or more times for the same defect, one or more times for a serious safety defect, or is out of service due to repair for a cumulative total of 30 days and the defect still exists".

Has anyone else on the board ever had to deal with a similar situation? I really don't want my, what I consider brand new, truck with 13K miles on it back after all that has been done to it + brand new engine. Thoughts?
 

·
Registered
Joined
·
984 Posts
I may be completely out of the park when I say this, but basing off of the behavior I can say check your cats. I drove my truck on a 2hr trip and it started acting clogged, then terrible performance. The blown cat basically crippled my truck to a crawl. Just my $0.02.
 

·
Registered
Joined
·
14 Posts
We need to know what all they checked, fuel pressure, alpha, IPDM, etc. The fuel pumps are bad about going out, the a/f ratio sensors are bad about going out and not setting a p2a00 code, the IPDM is bad about going out and setting any codes. Clogged cats can cause a misfire, in which case they need to disconnect the pipes and see if it improves. I'm sure they missed something.
 
1 - 13 of 13 Posts
Top