Nissan Titan Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
1,604 Posts
Discussion Starter · #1 ·
this tick noise is killing me. it sounds like its coming from the bellhousing but followed it up and its coming from the drivers side of the engine only but echos all around. figured probably the well known injector noise or maybe a valve lifter or spark arch. you can only hear it when the engine is at running temp. the warmer the eng gets, the louder the tick (almost a clunk) gets. you cant hear anything inside even under WOT (except for beautiful vk and banks of course lol).

i built a grounding kit and im going to install it tomorrow to see if it helps. im using 4AWG copper stranded wire and the activetuning directions. is there anything else i might be able to do, tricks or advise, to quiet the engine noise down? thanks in advance. :)
 

·
Registered
Joined
·
480 Posts
Long screw driver, let engine run and warm up, place it at the head, middle and bottom, with it pressed to your ear hole. report back.
 

·
Registered
Joined
·
1,604 Posts
Discussion Starter · #3 ·
will do when i get off work..what is special on the bottom middle of the head?
 

·
Premium Member
Joined
·
21,648 Posts
I've read where your oil filter can cause a ticking noise. Too much engine oil can too.
 

·
Registered
Joined
·
1,604 Posts
Discussion Starter · #5 ·
i actually just did an oil change w/ 6.9quarts of amsoil 5w30 w/ a K&N filter. i checked it the a couple days later and its touching the bottom of the top hole (full).
 

·
Premium Member
Joined
·
21,648 Posts
I don't know that it was a K&N oil filter that was the problem but one Titan owner switched brands and that helped. As long as the oil pressure is OK then it seems to me that the ticking (if caused by the oil filter) is an aesthetic issue, not a real problem.
 

·
Registered
Joined
·
1,604 Posts
Discussion Starter · #7 ·
ive used OEM, M1, and Royal purple as well and the sound has never changed. k&n seems to quiet cold starts down a little which is why i use it.
 

·
Premium Member
Joined
·
72,932 Posts
I always stop at 6.5 qts. :dunno:
 

·
Registered
Joined
·
1,604 Posts
Discussion Starter · #10 ·

·
Registered
Joined
·
1,604 Posts
Discussion Starter · #11 · (Edited)
pretty sure its the damn driver side manifold.....at 12k miles! this morning, i started hearing a louder tick sound and the engine sounded and idled like crap. sounds like a 'card and spokes' on the inside of the cab now...around the driver side windshield/dash area. i already checked to make sure it wasnt coming through the speaker. taking it to the dealer on friday.

this afternoon it ran ok...could still hear the tick inside but not near as prominent as this morning. its really weird that it only really does it when the engine is warm?? makes me think it might actually be a gasket and not the manifold itself.

btw...did the grounding kit mod and that didnt help with anything except a slightly smoother shifting tranny.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top