Nissan Titan Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey
just got an 05 titan 5.6 v8 not 4 wheel slip warning light is on as well as the abs light. whats going on can i deactivate slip? what do i need to get fixed to turn this light out?
thanks
bill
 

·
Registered
Joined
·
2,635 Posts
I cant help you but ive got the same problem, let me know when you figure it out and vise versa, when I find out Ill tell you as well
 

·
Registered
Joined
·
1,400 Posts
wiliam lothman said:
Hey
just got an 05 titan 5.6 v8 not 4 wheel slip warning light is on as well as the abs light. whats going on can i deactivate slip? what do i need to get fixed to turn this light out?
thanks
bill
My slip light will come on for a couple of days and then go back off.I would also like to know if you find out anything.I'm 90 miles from the nearest dealer so it's hard for me to take time out to get my truck in for service.
 

·
Registered
Joined
·
2,635 Posts
HudsonValleyTitan said:
Check your brake fluid level.
its fine unless it needs to be over the max line...
 

·
Registered
Joined
·
7 Posts
wiliam lothman said:
Hey
just got an 05 titan 5.6 v8 not 4 wheel slip warning light is on as well as the abs light. whats going on can i deactivate slip? what do i need to get fixed to turn this light out?
thanks
bill
I had the same thing happen to me (05 CC 4x4). The dealership had to replace the entire rear end. Thankfully, covered under warrantee.
 

·
Registered
Joined
·
12,754 Posts
If it is not your brake fluid it is probably the pressure swithches on the master cylinder. The dealer just replaced mine under warranty.
 

·
Registered
Joined
·
9,557 Posts
Al80872 said:
I had the same thing happen to me (05 CC 4x4). The dealership had to replace the entire rear end. Thankfully, covered under warrantee.
You must have had other issues then. The SLIP light uses the ABS sensors and braking system. It has nothing at all to do with the rear end operation.
 

·
Registered
Joined
·
33 Posts
Interesting, I have an 05' with 44,700 miles and my SLIP and ABS lights came on two days ago. Anyone know anythig yet? - thanks guys
 

·
Registered
Joined
·
97 Posts
Al80872 said:
I had the same thing happen to me (05 CC 4x4). The dealership had to replace the entire rear end. Thankfully, covered under warrantee.

same thing happened to me too. waited 5 weeks for a new diff to arrive. i was told theres a switch in the diff that is "non serviceable". switch goes bad, whole new axle, pretty dumb huh?
 

·
Registered
Joined
·
12,754 Posts
Veedo said:
same thing happened to me too. waited 5 weeks for a new diff to arrive. i was told theres a switch in the diff that is "non serviceable". switch goes bad, whole new axle, pretty dumb huh?
Glad you got a new diff, but there is nothing inside the diff that controls the slip, or the abs lights. They replaced the switches on my master cylinder, and it fixed mine.
 
1 - 11 of 11 Posts
Top