Nissan Titan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
183 Posts
Discussion Starter #1
It has been a while since I last posted anything here. I have enjoyed relatively trouble-free ownership of my ’06 Titan for a while after the initial kinks were taken care of. Currently, my Titan has 23,000 miles on it. Recently, the rear windshield started leaking water. They had to remove the rear windshield and re-caulk it to stop the leak. During the past few months, the “SLIP” indicator in the instrument panel came on several times when I was on the highway driving steady. They normally did not come back on after I turned off the ignition. I should have taking my Titan in to be looked at earlier, but I didn’t feel that I had the time to do that. Regardless, the other day, even after I parked and turned off the ignition and re-started the engine, the indicator remained on. I took my Titan to a local dealership today. After reading the stored error code, they contacted Nissan's techline and determined that some sensor went bad and the active limited slip control was applying brakes when it was not supposed to, causing the brake master cylinder and the sensor needing to be replaced. Quite frankly, I did not detect any abnormality when the "SLIP" indicator was on, and I feel that I am always “in-tune” with our vehicles any my motorcycle. Anyhow, the service department told me that they have seen this on other Titans and Armadas. I jut wanted to share this information just in case anyone out there is experiencing the same condition. I drove home in a rental Pathfinder, and my Titan should be ready tomorrow.

Cheers,
 

·
Registered
Joined
·
183 Posts
Discussion Starter #2
Quick Update and Correction

Just picked up my Titan. All they replaced was the brake master cylinder which was failing. I am surprised, but that was apparently the fix from Nissan's tech line. Also a correction. This particular dealership has not seen this problem before but Nissan has, according to the service writer.
 

·
Registered
Joined
·
6,370 Posts
Good info to know and be aware of. Thanks. Glad it's fixed now. :)
 

·
Registered
Joined
·
183 Posts
Discussion Starter #4
You're welcome. Now, the brake feels a bit mushy after they replaced the brake master cylinder. Maybe they didn't bleed the system well or it's just in my head...
 

·
Registered
Joined
·
71 Posts
Mine's gone.

ABS & Slip light came on.

Dealler sez Master Cylinder
they already have another Titan w/same issue.
 
1 - 5 of 5 Posts
Top