Nissan Titan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey guys, I recently purchased a used 2008 Nissan Titan SE and have been having some unusual brake issues. I was driving one day and pulled up to a stop sign and noticed the brake pedal sank to the floor and I wasn't sure I was going to stop in time. I noticed the 'SLIP' light come on, and it stayed on until I turned off/on the truck. I notified the dealership and they wanted to look at the truck right away. I brought the truck in and they couldn't initially figure it out so they brought it to the Nissan dealership. The Nissan dealership said the proportioning value needed to be replaced. My car dealer replaced the proportioning valve and master cylinder (as a precaution). All covered under warranty, I was a happy guy. Then I was driving through the Green Mountains and a guy in front of me decided to make a left turn without a turn signal and I had to put some real pressure on that pedal. I was probably going 50MPH and the pedal sunk to the floor. I was able to avoid a accident, but it was unnerving. If I'm going 45 or less, the brakes 'catch' and stop me as I would expect, if I'm going any faster, the brakes don't catch and the pedal sinks to the floor and I start praying to god that I don't kill anyone or myself.

So far, the master cylinder, and proportioning valve have been replaced. the brakes have been bled, the brake pads and rotors are good, whats wrong with these brakes, I'm nervous to drive it.
 

·
Registered
Joined
·
355 Posts
Ughhh... sounds pretty scary there. I had a brake piston on one of my front brakes blow a seal once (in a Dodge) and it did a similar thing. Pedal to the floor, ABS lit up. The fact it only happens above 50mph is concerning though. When mine went, it was a done deal. Brakes didn't work again so I wonder if it is with your ABS circuit. Do you notice if the brake pedal is vibrating like ABS is activating when it goes to the floor?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
there is no ABS pulsing. The pedal sinks until it reaches a stop point. By stop point, I mean the pedal just does not want to go any further, its not like a stop point where the vehicle stops.

The brake fluid is on the high mark and there are no apparent leaks in the lines.
 

·
Premium Member
Joined
·
20,940 Posts
Look up "delta sensor". This is a rare but known problem on the earlier years. I am not aware of it happening much at all on the later years (2007+).
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
OK, so I have some more information. I was able to figure out how to replicate the issue.

If I'm coasting downhill and have not had my foot on the gas for 10 or more seconds, when I press the brake I get no resistance and the pedal goes to the floor.

I also found that if I take my foot off the gas and immediately press the brake, the pedal is extra firm.

Keep in mind the dealership replaced the master cylinder in an effort to resolve this problem but it keeps happening.

It seems like if the engine is going at low RPM the brake is weak, but if the engine is running at higher RPM the brake is extra firm (and much more braking power) I have visually inspected the vacuum line that goes from the brake booster to the engine, it looks good. No, I did not do a fluid test on it.

Through my research, it seems that mentioning that the A/C is usually running when I have these issues may be relevant. I have not verified if there are still problems with the A/C off.
 
1 - 5 of 5 Posts
Top