Nissan Titan Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Recently got 06 Titan. A few weeks in the transmission seemed to be slipping in fourth gear. Today when I pulled out of my neighborhood I had barely any forward drive. The engine would rev but the transmission was slipping really bad in all gears and very jumpy. I quickly turned around and barely coasted into my driveway. It seemed to have basically no forward bite. I checked the trans fluid and it seemed to be at the correct level and didn't smell burned. Any ideas?
 

·
Super Moderator
Joined
·
37,163 Posts
1. how many miles?

2. Could be that there is antifreeze in the transmission. There is a common problem where the transmission is run through the lower section of the radiator, maybe a crack allowing the fluids to mix. <-- Take it to a transmission shop....

3. The clutch packs could be worn-out and need to be replaced = ~ $2500 - $4,000 <-- take it to a transmission shop

4. You could have it UpRev tuned ~ $700 and have the transmission line pressure increased... However, this would only be a band-aid. <-- take it to a tuner
 

·
Super Moderator
Joined
·
37,163 Posts
135,000 miles
Mine made it over 200,000 miles ... but still could be slipping clutches.

I would take a look at your radiator and see what color the fluid looks like.
 

·
Registered
Joined
·
289 Posts
Pull your pan check the screen see what it looks like. Sounds like it is on its way out and you should be visiting a trans shop soon
 

·
Registered
Joined
·
383 Posts
My 2006 Titan (165,000 miles) the tranny started slipping on the way home today. ?
Crap. No check engine light yet.


Sent from AutoGuide.com Free App
 
1 - 7 of 7 Posts
Top