Nissan Titan Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hey guys,

First post. Just bought a used 2008 Titan Pro-4X quad cab last week. Been having some trouble with the Nav system.

When I got the truck from Carmax, the factory DVD was all scratched up so the Nav system was not behaving. I can't seem to get the trip computer fuel mileage feature to work. Also, it was gaving trouble looking up destinations. I also couldn't find the "Vehicle Electronic Systems" option under settings. Anyway The DVD was a few years old and I wanted an up to date DVD so I ordered a brand new one. In the mean time, I figured the trip computer issue and "Vehicle Electronic Settings" issue were not a function of the nav DVD so I went to the Nissan Dealership to have them check it out while I waited for the new DVD to show up in the mail.

Basically, the Nissan service guys said couldn't figure out what was wrong. He said I needed to put "a few tanks of gas through the truck" before the Mileage and Distance to Empty displays would start working. He also said to try the new DVD when it showed up and that should resolve any issues. Sounded like BS to me but I said what the heck.

Well I got home today and and the new DVD was in the mail box. I popped it in and all the navigation features seem to be working just fine. I still have a problem with the trip computer though. It still is not displaying my fuel mileage or distance to empty. Also, I can not find the "Vehicle Electronic Systems" menu under settings. Even with the vehicle runnin in park.

Any ideas what the issue is here? According to my manual my truck should have both options. One isnt there, the other doesn't work. Any ideas?

Thanks,
Adrock1
 

·
Registered
Joined
·
34 Posts
Not sure if the navigation is the same or not between your year and mine. But to show the MPG and miles to empty on the nav you hit the Trip button and then keep hitting it and it will scroll through a few different features. I also think for your year(i may be wrong) you can display it on the vehicle information display. Where your guages are located their are 2 push button controls one on the right one on the left. The one on the right is your settings for choosing miles to empty, direction, temp ect. Just push it in. the same button also turns so to choose options just turn it. Hopefully this is what you were asking and will work for you, Otherwise hopefully someone else will chime in. ;)
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Not sure if the navigation is the same or not between your year and mine. But to show the MPG and miles to empty on the nav you hit the Trip button and then keep hitting it and it will scroll through a few different features. I also think for your year(i may be wrong) you can display it on the vehicle information display. Where your guages are located their are 2 push button controls one on the right one on the left. The one on the right is your settings for choosing miles to empty, direction, temp ect. Just push it in. the same button also turns so to choose options just turn it. Hopefully this is what you were asking and will work for you, Otherwise hopefully someone else will chime in. ;)
Yeah, my nav system is the same way. You press the trip button and it cycles through trip1, trip 2, mileage, and maintenance. Problem is when I get to the mileage/distance to empty screen it doesn't display any values, just asterisks.

Also, I still can't find the "Vehicle Electronic Systems" menu. I know it's supposed to be there because the manual references it and show how to use it, but when I hit the settings button, it just isnt there.

Back to the dealership I guess.

Adrock1
 

·
Premium Member
Joined
·
21,317 Posts
Is it possible that yours has been modded? If you can enter destination information while the vehicle is in motion then it has been modded.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
Is it possible that yours has been modded? If you can enter destination information while the vehicle is in motion then it has been modded.
not modded as far as I can tell, and Carmax said the vehicle had no modifications. I can't enter an address while driving. I attempted that today once I got the new DVD, but it would only let me enter a destination with the vehicle stopped.

As I have been tinkering with this thing this evening I'm noticing some other functions that I can not access. I was going through the manual and noticed the instructions for monitoring tire pressure. The tire pressure menus are not there.

So, so far, I have determined I can not find the Tire Pressure menus, the "Vehicle Electronic Systems" menu, and the Fuel Mileage and Distance to empty systems are displaying, but not functioning. According to my 2008 Titan manual, I should have access to all these features.

It occured to me that maybe these are optional features, but this truck is pretty well loaded. It has all the bells and whistles. Leather, sunroof, Rockford stereo system, heated seats, backup sensors, memory seats, power everything, bed rail system, dvd player, nav, tow package, e-lock diff, VDC, homelink, everything. From what I can tell this thing is fully loaded so I would expect all these systems should be functional. Heck, the "Vehicle Electronic System" functions should all be functional for any vehicle equiped with the Nav/Multifunction display system from what I understand.

I have read about some earlier versions of the system that have a "short menus" option. Is it possible that some of the features are just disabled?

Adrock1
 

·
Premium Member
Joined
·
21,317 Posts
I dunno. If it was an LE I would say all those features in the nav system should be active like they are on mine. It's almost like something is disconnected. But I can't imagine why menu items don't exist.
 

·
Registered
Joined
·
34 Posts
Maybe go into the nav settings and reset to factory default? just for ****s n grins its worth a try. That's werid though why it's just showing asterisks, maybe a short in the speed sensor?
 

·
Registered
Joined
·
686 Posts
I might try disconnecting the battery for an hour or so too. I had a similar problem with the clock not showing on my radio and disconnecting the battery for a while fixed that.
 

·
Premium Member
Joined
·
21,317 Posts
Distance to empty on my Nav is asterisks when I'm too low on fuel for it to accurately give a distance. Have you checked out the wires going into the back of the DVD player under the seat? I wonder if something is disconnected and the nav system isn't getting the feedback it needs from the sensors.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #10 ·
Well it's going to the stealership tomorrow. Gonna leave it for the day. Carmax is going to cover the bill. They cover it all for 30 days from the date of purchase. I can't figure it out and I've noticed even more missing features. I don't have a temperature reading on the display either for example. And this morning, the thing was toggling through screens by itself. One second the nav was working and the map was displayed, then all by itself it went to the trip screen, then it wouldn't go back to the map screen. This thing is goofed up. Hopefully the will just replace it.

Adrock1
 

·
Premium Member
Joined
·
21,317 Posts
That's not going to be cheap. Good thing it isn't your dime.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #12 ·
so they get the thing out and discover that it was simpley a loose connection. One of the wiring harnesses wasn't fully clipped in or something. All is working fine now. Thanks for the help anyway guys.

Adrock1
 
1 - 13 of 13 Posts
Top