Nissan Titan Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
So I was driving to work in my 2005 Le Rf with the music on and all of a sudden i hear the voice and music go off and all I hear is the bass? It did smell a little like something burning for a second, Can any one help me find out what went wrong? Nothing else in the truck failed everything else seems fine.. Thanks in advance:)
 

·
Registered
Joined
·
121 Posts
All electronics run off of smoke... If you let the smoke out of them then they don't work anymore..

Since you've still got bass the sub is playing sounds like the amplifier driving your main speakers has gone out. The subwoofer is still playing and the HU is still operating so I would point at the amplifier first, even though the subs are still operating that channel may be okay and the others burned out...

The amplifier itself is located under the dash apparently above the BCM as the removal instructions are as follows:

Removal and Installation of Audio Amp. EKS00AOT
1. Remove BCM. Refer to BCS-19, "Removal and Installation of BCM" .

Revision: October 2004 2005 Titan
2. Remove audio amp. bracket screws and slide audio speaker
amp. down.
3. Disconnect connectors and remove audio speaker amp.
4. Installation is in the reverse order of removal.
 

·
Registered
Joined
·
341 Posts
the rf amp for the speakers went out in my truck as well i just went and got a 4 channel amp for them and have not had a single problem since.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top