Nissan Titan Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
495 Posts
Discussion Starter #1
I have this light squeak from the left front suspension area every time I got in my car, start, shift from Park and lift off the brake pedal (just when the car starts to move). It happens sometimes during a turn too. I won't hear it if I push the car's front end up and down (like testing the shocks). I just had the Bistein HD installed in the front/rear but I am thinking it's from the anti-roll bar bushings eventhough I don't think it should happen to only 4 yrs old rubber bushings. I appreciate any suggestion.

Thanks
 

·
Registered
Joined
·
511 Posts
I've had this on both sides for so long I barely notice anymore. It used to drive me crazy, but I just try to block it out now.
 

·
Registered
Joined
·
4 Posts
I have the same problem. I was wondering about lubrication points under the chassis. I change my own oil about half the time but hadn't thought about chassis lubrication. Are there any lube points (zerk fittings) for the steering or suspension?

Physix


amati5 said:
I have this light squeak from the left front suspension area every time I got in my car, start, shift from Park and lift off the brake pedal (just when the car starts to move). It happens sometimes during a turn too. I won't hear it if I push the car's front end up and down (like testing the shocks). I just had the Bistein HD installed in the front/rear but I am thinking it's from the anti-roll bar bushings eventhough I don't think it should happen to only 4 yrs old rubber bushings. I appreciate any suggestion.

Thanks
 

·
Premium Member
Joined
·
31,154 Posts
I had the same squeaks and used spray lithium grease at all points of contact on leaf springs and suspension and it went away like magic.....

Good luck...
 

·
Registered
Joined
·
51 Posts
I had this same issue and while I was still under my warrenty I told the dealer it sounded like a rusty old truck when I got into/out of my truck. They said it was coming from the rear driver side leaf spring. They put some lubricant on it and that fixed it.
 

·
Registered
Joined
·
495 Posts
Discussion Starter #7
redneckpapa1996 said:
I had the same squeaks and used spray lithium grease at all points of contact on leaf springs and suspension and it went away like magic.....

Good luck...
Over the weekend I sprayed some silicon at the aiti-roll bar bushings without removing them. This monring I didn't think of it but then I don't remember hearing the squeak anymore. I'll listen again later today and if it's still there, I'll try the spray grease. Sounds like a good solution. Thanks
 

·
Registered
Joined
·
495 Posts
Discussion Starter #8
IGBT said:
..are they rubber susp.bushings??
Not sure, I was just assuming most stock cars come with rubber bushings which usually don't require regrease too soon.
 

·
Registered
Joined
·
223 Posts
physix said:
I have the same problem. I was wondering about lubrication points under the chassis. I change my own oil about half the time but hadn't thought about chassis lubrication. Are there any lube points (zerk fittings) for the steering or suspension?

Physix

no lube points in the titan. i asked the guy at jiffy lube and he told me there are no lubes on the titan
 
1 - 9 of 9 Posts
Top