Nissan Titan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
MY 08 Nissan Titan is having issues starting. It turns over but wont start. I have to attempt to start it a couple times before it starts. The service manager said that it sounds like the crank sensor. Anyone have this problem? If so, was it the crank sensor?
 

·
Registered
Joined
·
22 Posts
It's possible it could be that. It is a sensor or component that monitors the position or rotational speed of the crank. Engine management systems use the information transmitted by the sensor to control things such as ignition timing and other important functions. The crank position sensor can be found in the front of the crank on the engine block below or next to the water pump in many applications. It can also be located near the main crank pulley or the flywheel.
It also may be the IPDM-ER. Sometimes it will start only to die shortly after.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thank you for the information. Once my truck starts, it runs fine. It's not a constant problem. It just seems as though its getting worse. The service engine soon light came on and when I went to the auto parts store to have the code checked, it came back as the park/ neutral/ safety switch. I'm probably going to change the crank sensor and see if that corrects it.
 

·
Registered
Joined
·
34 Posts
my titan periodically will not start, it turns over but wont fire up.. its happened about 3 times since ive had it and i now have 48k on her. i think its related to the neutral safety switch. when it does this i somewhat giggle the gear shift lever (while in park of course) and then it starts.
 
1 - 4 of 4 Posts
Top