Nissan Titan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
207 Posts
Discussion Starter #1
I've noticed something the other day with steering wheel shudder, but I'm not sure if it's a problem or if it's just normal.

When the truck is stopped, if I turn the wheel to the left to near lock, the steering wheel will noticeably shudder. You can feel it right before you get to maximum turn. It only seems to do it when the truck is at a complete stop. I've got the 20" wheels with what seems to be fairly wide tires.

Does anyone else notice anything like that on their Titans?
 

·
Registered
Joined
·
1,194 Posts
sounds like the PS pump is struggling to extend to lock (which is tough on any PS set-up, especially when not moving)

When was the last time the belt was changed? You may have slippage under load there.

Any PS Pump issues? Fluid leaks?
 

·
Registered
Joined
·
207 Posts
Discussion Starter #3
sounds like the PS pump is struggling to extend to lock (which is tough on any PS set-up, especially when not moving)

When was the last time the belt was changed? You may have slippage under load there.

Any PS Pump issues? Fluid leaks?
It's a 2015, about 7 months old. So the belt should be new. No leaks that I've seen. Maybe it's low on fluid?
 

·
Registered
Joined
·
207 Posts
Discussion Starter #4
It's a 2015, about 7 months old. So the belt should be new. No leaks that I've seen. Maybe it's low on fluid?
I had a chance to get under the hood this morning. The power steering fluid is topped off. So, it not low fluid.

Maybe this is common with all Titans with the 20" wheels?
 

·
Registered
Joined
·
207 Posts
Discussion Starter #5
The problem has continued, but for a while, the fluid was clear. I decided to keep an eye on it.

Well, I checked the fluid the other day, and now it's black. Worse, it's leaking through the cap at the top of the reservoir. Clearly, there's a problem. I'm still under warranty, though, so I'm glad whatever is wrong is happening now instead of later. My guess is the pump was marginal when it was installed at the factory, and it's going out early. I'm hoping they will just replace the entire system.
 
1 - 5 of 5 Posts
Top