Nissan Titan Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
5,748 Posts
Discussion Starter · #1 ·
I installed the stillen leveling kit I got from the dealer last night, and, well, it seems like I got more than 2" of lift!!! The spacer itself is 2" thick but the truck looks like it's like 3"-4" higher! My camber is all out of whack(positive camber up the wahzoo). Also, the upper control arm was a pain in the A$$ to get back bolted up to the spindle!

What I'm wondering is, is this normal??? I have the off road package if that helps.

I would have gotten the prg leveling kit if i would have known of this forum before I ordered the stillen. I will be ordering the rear kit and the front bump stops so I don't blow out my front struts the first time i go off roading with the kit....

Will I be able to get the truck back in alignment? It looks pretty bad right now.... Thanks in advance!

Casey :smoke:
 

·
Registered
Joined
·
294 Posts
Did you have the sway bar end links disconnected while you were trying to connect the upper arm? I know the first time I installed my PRG level kit I did not unbolt the sway bar and had all kinds of trouble.

Now that you know about Greg (PRG) I would highly recommend you get stuff from him. His customer service and knowledge of the Titan is unmatched.
 

·
Registered
Joined
·
2,725 Posts
dude. call [email protected] since you picked up his stuff. he's a good guy. I'm sure he'll try to help you.
 

·
Registered
Joined
·
5,748 Posts
Discussion Starter · #4 ·
I'm not having problems with the kit, I was just wondering if this is normal..... I also forgot to unbolt the sway bar, then the light went on and i figured it out.

This is the third try for me in leveling the truck out. The original procomp one I bought was a piece of garbage. The coil spacers weren't even the same for my application!!! one of them was for a dodge ram?!?!?! I talked to the dealer about it and they said that they have been having problems with procomp for a while. And they're thinking of dropping them from their sales.

*correction* there was just one small problem with the kit actually. The nuts that go in the spacer section that bolts to the top of the strut assembly were the wrong nuts. They would fit in the holes, but there was NO WAY to get a socket in there to tighten them up. I brought the kit with me to stillen day and talked to El Hefe and he straitened everything out for me with some new shouldered nuts. Props to the big man there at stillen.

Casey :smoke:
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top