Nissan Titan Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
707 Posts
Discussion Starter · #1 ·
2007 with manual HVAC:

I get into my truck today with the AC system "off" by the fan knob. The temp was at max cold and the mode knob was at "MAX AC". BUT, the blower knob was to "OFF". As I was driving, I decided to push the recirculation button to allow fresh air into the cab as I drive, and when I pushed the recirc button I heard a relay clicking away repeatedly under the dash on the passenger side. I looked at my HVAC panel, and the recirc and AC LED's were blinking on and off with the relay clicking. I also could tell my compressor was kicking on and off too. So I moved my mode knob to upper vents and this problem stopped.

Is my HVAC controls crapping out? I know that the "MAX AC" mode requires recirc air only, and normally it will ignore when you push the recirc button. I don't think it should be doing this when the system was in the "OFF" position.
 

·
Registered
Joined
·
707 Posts
Discussion Starter · #2 ·
Today I was trying to determine if I have an exhaust leak (another problem there!) and as I was looking around the engine bay while the truck was idling, the AC compressor was kicking on and off. I looked in the truck at the HVAC controls, and the master (fan speed) was in the OFF position. I pushed the recirc button and the LEDs in the HVAC panel started freaking out.

I'm pretty sure the HVAC control panel isn't really broken, but it's either the solder joints going bad or tin whiskers from when PCB manufacturers switched over from lead based solder to non-lead solder for ROHS crap.

My Maxima with nearly 300K miles has always run like a champ, and my Titan with 26K already needs a few grand in warranty repairs....:bangit:
 
1 - 2 of 2 Posts
Top