Nissan Titan Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
342 Posts
Discussion Starter #1
So I had the gas saver tune on my 2007 and I went to put the 87 tune on. There was a communication error and I got error G-58. I try to return to stock and it won't let me and now the truck won't start. Tried calling Superchips but they are closed. Any ideas? can I reset the truck?
 

·
Registered
Joined
·
1,518 Posts
Make sure everything is turned off (radio, air, wipers, etc.) and all the connections are secure. Then try again. If that doesn't work, check fuses. Other than that, IDK.
 

·
Registered
Joined
·
3,233 Posts
in addition, if its anything like the BDGT - disconnect the battery for 10 mins and then re-connect...see what happens.
 

·
Registered
Joined
·
14,137 Posts
You might be loosing voltage somewhere. Mine did this too cause i tried tuning it with the door open and left it for a while, the lights being on drained too much voltage. I unhooked and came back an hour later and tried it again, this time it worked. Send Scott at superchips a message and he is good at getting back to you. Although its saturday so idk what their hours are.

Is the fan running and the truck turning over really fast? Thats exactly what mine did.
 

·
Registered
Joined
·
342 Posts
Discussion Starter #5
Fixed! Disconnected the battery for a bit and it worked! I believe the problem was a combination of things, but the door being open is one of them.

Thanks guys!
 

·
Registered
Joined
·
1,518 Posts
Glad you got it fixed/worked out.
 

·
Registered
Joined
·
12 Posts
Thank you!!! Left my door open and played around for too long and got the same error code. Titan wouldn't start and it was after hours. Disconnected battery, Waited, charged battery and I'm back in business.
 
1 - 7 of 7 Posts
Top