Nissan Titan Forum banner

Tail light help

1368 Views 9 Replies 5 Participants Last post by  bbenjamin21
Yesterday I got a fix it ticket for my rear left running light being out. I went and got new bulbs. I replaced both left and right even tho the right wasnt out. Just figured minaswell, well my left still is not working. Is there separate fuses for each tail light. I thought if it was the fuse, both sides would be out. My blinker and reverse still work on the left so I don't know wut it could be. I hope it's not wiring??

06 Titan se
1 - 10 of 10 Posts

· Premium Member
Joined
·
142,009 Posts
Swap bulbs left to right to eliminate chance of bad bulbs.
 

· Registered
Joined
·
1,073 Posts
I've always been told that you shouldn't replace both bulbs at the same time because the possibility of them both burning out at the same time is increased. Maybe it's an old wives tale...but I offer it for what it's worth.
 

· Registered
Joined
·
34 Posts
Discussion Starter · #8 ·
I took my meter and I'm reading nothing through the socket. So it's definitely a wire problem. I'm honestly starting to dislike this truck. I mean I love it but there's just problems after problems lately. Rear axel seal, and when i changed the oil a week ago it looks like the transfer case in the front is leaking and now this. Getting annoying.
 

· Registered
Joined
·
928 Posts
I am guessing it is your passeger side rear light? if so check under the exhuast. follow the pipe and see if the cables are melted off or burned. They are in such close proximity and other users have reported this on other threads.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top