Nissan Titan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
785 Posts
Discussion Starter #1
Got back from my business trip yesterday and was able to install my box and sub this afternoon. The single 12" box works great and now I have plenty of "bump" with the Treo TSI sub powered by an Alpine M450 amp running off the stock HU.




 

·
Premium Member
Joined
·
5,015 Posts
Glad it worked out for bro. I like the way the sub looks. Like an old school sub.
 

·
Registered
Joined
·
4,808 Posts
I do like that... and its old skool too!

Looks like you should try to raise that seat a bit!
 

·
Registered
Joined
·
1,237 Posts
that looks good - I have the same box from Tech - it looks like you should slide yours toward the front of the truck about 3 more inches. I had mine in about the same spot as you and when I raised the seat I saw marks where the Sub was contacting the bottom of the seat. I keep mine bumping hard when I'm alone though (90% of the time). you can probably keep it there if you don't turn it up too much though....
 

·
Registered
Joined
·
785 Posts
Discussion Starter #6
Fox Delta said:
that looks good - I have the same box from Tech - it looks like you should slide yours toward the front of the truck about 3 more inches. I had mine in about the same spot as you and when I raised the seat I saw marks where the Sub was contacting the bottom of the seat. I keep mine bumping hard when I'm alone though (90% of the time). you can probably keep it there if you don't turn it up too much though....
I already did that, the Treo has decent excursion so I moved it forward to be safe. I'm still messing with the amp setting but for a sub $100 sub this thing can dig pretty deep.
 
1 - 6 of 6 Posts
Top