Nissan Titan Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2,986 Posts
Discussion Starter #1 (Edited)
As most people know, I have had a lot of problems with my truck for various reasons. The latest was my truck was running very lean. The truck had an A/F ratio of 14.56 @ WOT.

I logged some data from a WOT run and sent it to Kyle and the Big 3. Randy said not to run the truck again otherwise I would be on my third motor. Kyle agreed with Randy, so I kept the rpm below 2k until Stillen could look at the data.

Kyle and Cullen overnighted a new piggyback and harness for the dealership to install. I chose a different dealership to return the Nissan wiring harness back to stock and install the new piggyback.

Dave at LIA Nissan reversed the shameful wiring job done by Harte Nissan, then throughly tested and retested the AF, fuel pressure, timing, etc. Now the truck runs they way it was supposed to run. I don't know how Dave did it but he set the speed limit at 120. I asked him what he did and he just smiled.

I will log some data tomorrow and head back to the dyno in a couple of weeks.

If it were not for Kyle, I would have lost another motor and of course I would have gotten rid of the Titan.
 

·
Registered
Joined
·
6,373 Posts
How did you find it was 120? :)

Glad to see such cooperation can still exist. Good to see how you have followed through, we need more guys like you.
 

·
Registered
Joined
·
2,952 Posts
TitanBlue said:
How did you find it was 120? :)

Glad to see such cooperation can still exist. Good to see how you have followed through, we need more guys like you.
Hell yeah - service like that strengthens the brand. Nissan should be sending bonuses anytime guys go above and beyond.
 

·
Banned
Joined
·
6,454 Posts
i'm confused. Pardon my ignorance in advance, but you seem to be hinting that a dealership could have wired something wrong? What besides the piggyback is needed to be wired? Fuel pump, regulator???? But you dont mention that. And how did a dealer override the PNP Stillen piggyback?Sounds like Stillen is having tuning issues to me. So did you tell the dealer what A/F ratio to run??? If not you have some damn good techs at your dealership.
 

·
Registered
Joined
·
2,986 Posts
Discussion Starter #5
roy365 said:
i'm confused. Pardon my ignorance in advance, but you seem to be hinting that a dealership could have wired something wrong? What besides the piggyback is needed to be wired? Fuel pump, regulator???? But you dont mention that. And how did a dealer override the PNP Stillen piggyback?Sounds like Stillen is having tuning issues to me. So did you tell the dealer what A/F ratio to run??? If not you have some damn good techs at your dealership.
Harte Nissan did the install of the kit. There is a lot of wiring that must be done with the kit. The quality of the wiring performed by Harte Nissan was substandard to say the least. We weren't able to tell how bad it was until we untangled the spaghetti they left.

The dealership did not override the p-back. I logged some data and sent it to Kyle. He in turn gave the data to his R&D guy and fixed the problem via a new p-back, tune and harness.

The tech and I believe it was actually the hack of a wiring job performed by Harte Nissan that caused the lean condition. The wires seemed not to be making connection all the time. Fuel pressure went from 70 psi @ idle to 40 psi @ WOT.
 

·
Registered
Joined
·
2,518 Posts
glad you got some more fuel in there Chad. Thank the powers that be that Uprev had a way to offer the data log to Stillen. So did you get the new plug and play harness?
 

·
Registered
Joined
·
2,518 Posts
QShip said:
The tech and I believe it was actually the hack of a wiring job performed by Harte Nissan that caused the lean condition. The wires seemed not to be making connection all the time. Fuel pressure went from 70 psi @ idle to 40 psi @ WOT.
Wow stock is 52psi under WOT? What is now?
 
1 - 7 of 7 Posts
Top