Nissan Titan Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter · #1 ·
We went boating this weekend and I towed my boat across the Utah desert and in the course of three days two strange things happened for the first time.

1. Out of the blue, the passenger side vents started blowing out hot air while the driver side continued blowing cool air. Nobody touched the controls and they were both at 60. I turned off the system for about 5 minutes and the problem went away.

2. A couple days later, I noticed that with the fan control at full the air was blowing very softly. As I started to turn the dial back to 1, the fan started blowing stronger. And with the dial at 1, it was blowing full blast. That's right the dial was working opposite of the way I turned it. After turning off the system the problem corrected itself.

What could this be???
 

·
Premium Member
Joined
·
15,691 Posts
mine does the hot and cold thing. its normally when its on auto and getting close to the temp i have set. it sucks, and i wish i could fix it.
 

·
Registered
Joined
·
113 Posts
Mine's acting screwy as well. When the fan is on high, it will randomly stop blowing totally for about 3-4 seconds, then start again. Today, I have the fan on the lowest setting and it's blowing at medium speed, and I have to crank it all the way to high to bump it to the high speed. Won't blow at low speed. Just started doing this in the last few weeks. Any ideas?
 

·
Registered
Joined
·
1,614 Posts
Mine's acting screwy as well. When the fan is on high, it will randomly stop blowing totally for about 3-4 seconds, then start again. Today, I have the fan on the lowest setting and it's blowing at medium speed, and I have to crank it all the way to high to bump it to the high speed. Won't blow at low speed. Just started doing this in the last few weeks. Any ideas?
Same here 08 Titan
 

·
Premium Member
Joined
·
15,691 Posts
the changes in speed are probably that VBC resistor. it may be going out.
 

·
Premium Member
Joined
·
15,691 Posts
that is the resistor going out. unless the climate controle is getting confused.
 

·
Registered
Joined
·
708 Posts
I highly doubt it is the blower resistor. Blower resistors fail open, meaning they will only work when selected to HI speed. For your auto hvac to be selecting different speeds tells me it is in the PCB assembly in the dash. That is also why the air temp was changing in the OP's 1st post.

I have a 2007 with manual hvac, and it is freaking out also. Sometimes my AC compressor comes on when the system is off, or my LED's blink on and off as a relay clicks in unison with the LEDs.

As an electronics guy, I can almost surely say it is the control PCB directly behind the knobs/display of the hvac controls. And, most likely it is a phenomenon called "tin whiskers", when the electronics industry was forced to abandon lead solder, tin based solder was used instead. Tin solder grows whiskers that conduct. The SMD PCB in our trucks have very small components and traces and are highly susceptible to this problem.
The other problem is possibly just bad solder joints.

But either way, it is an unacceptable problem, that Nissan can easily solve and make right. Of course, Nissan will never state that they have a problem....

When mine stops working, I will try to resolder the whole PCB myself, using old school lead solder. I don't want to pay big $$$ for a new control unless Nissan actually FIXES them and revises the part number
 

·
Registered
Joined
·
3 Posts
I have a 2008.5 Titan SE and have the same "ghost" problem. It's a manual HVAC control and at random times, the fan blower will go to max speed (with setting typically around mid-range, but not required) for a few seconds (sometimes more), then returns. During this freak-out you can't control the speed - just have to wait it out. I took it back to the dealer and they replaced the rheostat which didn't solve anything. Then took it in again and they replace the entire HVAC unit. Didn't solve anything. That was in Delaware where I bought it. Now that we've moved to the west coast, I took it in again and this dealer said there is nothing wrong with it. It still does it... I have about 2 months left on remaining factory warranty, but if the dealer says "nothing is wrong," what are we supposed to do? Frustrating... especially when in warranty / has a problem, yet they wont do anything to fix it!
 

·
Registered
Joined
·
61 Posts
So heres my 2 cents. My Titan was doing the same thing but with the heater. Took it to the dealer and they told me one of the hoses has some kind of electronic component on it and it was going out. Once I replaced it the problem went away.

I love Nissans all together but it seems like their climate control systems are not up to par with other the other makes. Ive never seen a vehicle still blow air out the vents when your system is completely off(My dads frontier does this and my moms g35 does it too).

But still I see Nissans vehicles superpurb to other vehicles on the road
 

·
Registered
Joined
·
13 Posts
I have a 2004 SE, manual climate controls, my vent selector intermittently selects the wrong vents, or just stays on defrost no matter where the knob is. If I replace the control behind the faceplate, that should fix it? Thanks.
 

·
Registered
Joined
·
113 Posts
I just got a recall notice for my 2010, says the HVAC control motors may need to be replaced. Dealer says it is a 5 hour job. Don't know if it's related to your issues, but worth checking into.
 
1 - 12 of 12 Posts
Top