Nissan Titan Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
2,635 Posts
Discussion Starter · #1 ·
okay, so if you did not know heres my story in a nut. If you want more info search for it.. too much typing to me..

First my brake light, and battery light were both on... 100 miles later the truck died and left me stranded way late in the night...

Tow it to the dealer, they keep it for a week, replace the battery.. woohoo its like new.. so they say...

A month later maybe ??? My ABS, BRAKE, and SLIP lights both stay lit when I start the truck sometimes...they have been on and off for the past month or so.. check thread dates for exact time...

Anyways got up today and the lights were on again, already pissed of at something else, I decided to go give them grease monkeys a piece of it...


Later I get a call.. oh the altenators bad, it needs replaced.... OH REALLY ?Didnt I tell you that was the problem the first time ??? (which I did)... but no.. that was not the case.. I just happend to have a battery died 80months ahead of time...fkers probably did not even think about touching the alternator...but of course they cant stop telling me about how it really did work...

So anyways I get her back tomorow, the new alternator isnt there yet...so they gave me this cool new Altima off the lot with the v6 6speed shift tronic ??? 6sp, with no clutch.. its really fun and peppy but nothing near my titan ! So we will see if I have anymore problems.. if so the truck is probably going to be traded in.. yes.. for of course a NEW titan lol...I think Ill be stuck on Titans for the next 10 years or so haha...
 

·
Registered
Joined
·
2,635 Posts
Discussion Starter · #2 ·
BTW- they are keeping my truck for another day... lets see what they say tomorow !... I do like the push button start in the altima, and no key lol
 

·
Registered
Joined
·
3,363 Posts
yea push button start kicks *** :) Would be nice on the titan too.
 

·
Premium Member
Joined
·
76,498 Posts
i thought they finally decided it was "user error" and called it quits!

haha jk dude. hopefully this will solve your woahs.. take any pics of that altima... in your driveway perhaps ;)

try jacking the push button and installing it on your titan
 

·
Registered
Joined
·
2,635 Posts
Discussion Starter · #6 ·
OMG I want that push button.. so much better then digging for keys.. I cant get a hold of my service manager right now so apparently its not done... Im just waiting for them to tell me its gotta stay another night.. it does not bother me but dont tell me ONE day when its going to be 3 or 4... thats wrong...and sure Ill go snap some pics of the altima for ya in a few
 

·
Registered
Joined
·
2,518 Posts
wife's new camry has that shiftronic and push button...I would have never thought a camry would have those things in it.

Call that dealer again and again. Better yet tell them that if they can't find teh problem this time that you'll take an 07 off the lot.
 

·
Registered
Joined
·
2,635 Posts
Discussion Starter · #8 ·
RB's Titan said:
wife's new camry has that shiftronic and push button...I would have never thought a camry would have those things in it.

Call that dealer again and again. Better yet tell them that if they can't find teh problem this time that you'll take an 07 off the lot.
elaborate on that ? I already have an 07, and the only 07 they have left is an over priced lifted king cab...if it were a cc it would be awesome lol...
 

·
Registered
Joined
·
2,635 Posts
Discussion Starter · #9 · (Edited)
Got my truck back and Im not any more happy then I was stranded on the side of the rode... anyways shes running fine... but

1. They did not fix any of the 3 squeeking seats for the 3rd visit !
2. They took 3 more days that the original date.
3. There is WD40 EVERYWHERE in my truck and is giving me a bad headache...
4. They patched my tire rather than replace it...why I care ?
5. There is white paint on my passenger seat now.. WHAT were they painting !??!
Because I paid over $500 for the service plan that gives me NEW tires no question asked whenever there is anything letting the air out...and they just patched it.. but W/E I dont really care too much

Then they tried to give me the run down on how I broke the alternator... They were saying they found water in it...and thats what caused it to crap out...I doubt it.. Its been dead for 2 months now and I told them that.. they didnt fix it.. but I did take the truck in the mud the day before it went to the dealer and the only reason they know is because I never got a chance to wash it.. just pressure wash.. so Ill keep up if I start throwing lights again.. which I hope not.. and IDK why but the dealer ONLY had 3 TITANS TOTAL ! Usuallly there is 20 to 30 on the lot and another dozen or more in the back! who knows... I guess they are selling like hot cakes !
 
1 - 9 of 9 Posts
Top