Nissan Titan Forum banner

1 - 20 of 68 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
Hey Guys,

New here. Just bought a 2021 Pro 4x last week. Love the thing. Issue I'm having is a delay in response when i press the pedal. This is only an issue when I'm taking off from a stop or slow roll (1st gear). I'm assuming it may be a gearing ratio thing? I'm not sure. I also have played around and I see the response is slightly better if I press the pedal down with my toes at the top of the pedal vs resting my heal on the floor and pressing the pedal towards the bottom. Still a delay, but noticeable.

Anyone else have this issue? Maybe a flash and configuring to fix this? It bugs me to press the pedal down, even slightly, and have a good half second delay and then truck jolts forward like I've been spraying fuel for half a second before combustion happens.

Any insight would be great!

-Andy
 

·
Registered
Joined
·
344 Posts
Does it do it every time or randomly? The transmission in these trucks are something of a conundrum. Im having what I feel are issues with mine. Delay, 1st gear being real jerky, when the trans is cold Im getting a lot of slip until it warms up. Odd stuff. Mines a 21 P4X with 900 miles on it
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #3 ·
Does it do it every time or randomly? The transmission in these trucks are something of a conundrum. Im having what I feel are issues with mine. Delay, 1st gear being real jerky, when the trans is cold Im getting a lot of slip until it warms up. Odd stuff. Mines a 21 P4X with 900 miles on it
Its EVERY time. I have not even 200 miles on mine. I saw where this was an issue in 2017 and someone said they had the gearing remapped but now i cant find the forum lol.

I'm going to throw on the Nismo exhaust that Z1 Offroad sells and will have them remap it then and see if they can help me out.
 

·
Registered
Joined
·
344 Posts
Yeah the delay seems to be random on mine. When I was researching the truck I found one reviewer that experienced it every time like you are. I believe its a lag in the throttle by wire system.

Im giving mine to 1500 miles and if its still acting up, its going back to the dealer. Sometimes mine is smooth and shifts nice and the next minute its a stumbling mess and cant figure out what gear it wants to be in or even between gears sometimes. Its starting to become very annoying.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #5 ·
Yeah the delay seems to be random on mine. When I was researching the truck I found one reviewer that experienced it every time like you are. I believe its a lag in the throttle by wire system.

Im giving mine to 1500 miles and if its still acting up, its going back to the dealer. Sometimes mine is smooth and shifts nice and the next minute its a stumbling mess and cant figure out what gear it wants to be in or even between gears sometimes. Its starting to become very annoying.
So, when i'm out of 1st gear and going, shifting is smooth and I don't seem to have a delay at all? Just seems 1st gear only, but its all the time. I warm the truck up and everything. I'll call my dealer and see if they can take a look at it and fix it?
 

·
Registered
21 Pro4X
Joined
·
21 Posts
Same thing is happening with mine, around 1k miles now. I brought it back to dealer around 200 miles and they opened a tech ticket with nissan but did not find anything. going to drive it for a while and see if it gets any better. I initially brought it back to dealer for the downshift issue, from 2nd to 1st there is a noticeable "thunk". Of course they did not find anything at this time. I feel it's probably something they can fix on a transmission reprogram, but i dunno we will see.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #7 ·
Same thing is happening with mine, around 1k miles now. I brought it back to dealer around 200 miles and they opened a tech ticket with nissan but did not find anything. going to drive it for a while and see if it gets any better. I initially brought it back to dealer for the downshift issue, from 2nd to 1st there is a noticeable "thunk". Of course they did not find anything at this time. I feel it's probably something they can fix on a transmission reprogram, but i dunno we will see.
I'm taking mine in at 715am tomorrow. I'll let you know what they say (or not say) as I'm sure if its not going to throw a code, they arent going to do anything, I'm quite sure.
 

·
Registered
21 Pro4X
Joined
·
21 Posts
I'm taking mine in at 715am tomorrow. I'll let you know what they say (or not say) as I'm sure if its not going to throw a code, they arent going to do anything, I'm quite sure.
keep me posted. they even drove me around in a new Titan and it did the same. One thing that I am fighting to see if it is an issue is the electric brake booster makes a grinding noise. It happens randomly and almost always the same amount of time. it's annoying as heck
 

·
Registered
Joined
·
62 Posts
I have a new 2021 SL 4X4. I have the throttle delay and the herky jerky 1 to 2 up and down shift. I only have 500 miles on it so will give it a little time to see if it heals itself. Disappointing though for $60K truck. It should shift right and respond from the git go.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #10 ·
I have a new 2021 SL 4X4. I have the throttle delay and the herky jerky 1 to 2 up and down shift. I only have 500 miles on it so will give it a little time to see if it heals itself. Disappointing though for $60K truck. It should shift right and respond from the git go.
Yea man I'm at the service center as we speak while they take a look at it. I'll let you know what they say. $61k truck should run like a top.
 

·
Registered
Joined
·
344 Posts
I have a new 2021 SL 4X4. I have the throttle delay and the herky jerky 1 to 2 up and down shift. I only have 500 miles on it so will give it a little time to see if it heals itself. Disappointing though for $60K truck. It should shift right and respond from the git go.
Ahh man I hate hearing this. More folks coming out of the wood work about their issues with the trans.
 

·
Registered
Joined
·
62 Posts
Ahh man I hate hearing this. More folks coming out of the wood work about their issues with the trans.
Yeah, I hate that search shifting and throttle delay when you first take off. The problem is you never know what it is going to do when you first accelerate, its a little unnerving pulling into traffic, of course you always have the heavy throttle option, then everything works the way it should for the most part. I gonna give it some time, but its aggravating as hell right now. Otherwise, I love this truck, nicest Titan I have owned. Hope they find a fix or it straightens itself out soon.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #14 ·
UPDATE

Well guys, I have News. Good and Bad lol.

So, I took the truck to Nissan and they said what I assumed they would. Said theirs's no codes so there's nothing to "fix". Their offical words from the 2 mechanics were "We dont really see too many 2021 Titans come in but we drove your truck, another 2021 and a 2019. There was no difference between your truck or another 2021 but we could tell what you mean by driving the 2019. They essentially said the truck "drives as designs" and is claiming that the new 9 Speed transmission (the 2019 had a 7 speed). The mechanic said a fix could be getting a throttle tuner or taking it to a shop to have the throttle tuned to remove the lag as this issue only effects 1st gear? I shouldnt HAVE to take a $60k truck into a shop to retune the throttle, but alas, here we are.

So for all of you thinking it will get better, from their words, there's nothing wrong with it. Its just doing what its designed to do (probably a gearing issue of some sort that I figured it was.

Now, where to find a place to tweak and tune the throttle response and fix it..... :cautious:

Hope this helped or shed light for everyone. Attaching official statement below from service center. Would be nice to have an official "Nissan Corporate" on this.

549716
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #15 ·
Yeah, I hate that search shifting and throttle delay when you first take off. The problem is you never know what it is going to do when you first accelerate, its a little unnerving pulling into traffic, of course you always have the heavy throttle option, then everything works the way it should for the most part. I gonna give it some time, but its aggravating as hell right now. Otherwise, I love this truck, nicest Titan I have owned. Hope they find a fix or it straightens itself out soon.
Oh and yea man, the traffic thing is the reason why I took it in, damn near smoking the back tires off coming out of my neighborhood. All I hear is "dang Daddy, calm down" from the back seat drivers :ROFLMAO:
 

·
Registered
21 Pro4X
Joined
·
21 Posts
Thanks for the feedback. I am wondering if one of those pedal commander type things would help, but like the consensus states, wth should we have to do that with a 60k truck :(
 

·
Registered
Joined
·
344 Posts
Yeah, I hate that search shifting and throttle delay when you first take off. The problem is you never know what it is going to do when you first accelerate, its a little unnerving pulling into traffic, of course you always have the heavy throttle option, then everything works the way it should for the most part. I gonna give it some time, but its aggravating as hell right now. Otherwise, I love this truck, nicest Titan I have owned. Hope they find a fix or it straightens itself out soon.
Yeah its weird. Try to be nice and smooth and it acts up but put your foot in it and it drives right. Doesnt make sense.

I have heard on here and a couple other places that a Pedal Commander or a Sprint Boost like TitanAndy mentions above has worked wonders. I had one on a 2017 Expedition (think throttle by wire lag and turbo lag combined) and it made a world of difference. I had one on my 2017 Chevy 1500 (it had a off the line lag similar to what some of us are experiencing with our Titans) and it pretty much eliminated it.

Might be worth trying. Id rather spend the $300 on something else but if it improves drivability then its probably worth it.

If the Nissan mechanics are recommending it then you know there is no oem fix.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #20 ·
Thanks for the feedback. I am wondering if one of those pedal commander type things would help, but like the consensus states, wth should we have to do that with a 60k truck :(
So I personally did notice a difference in response by just the placement of my foot on the pedal. I moved my toe to the top of the pedal and the lag was much less. It could simply be a slight change in the position of the pedal or maybe taking out some play in it? really dont know outside of taking it into a shop and let them have it for the weekend to play with options. Whatever shop figures out the trick, especially if its an ecu throttle tune, can make some money from it. I'd gladly pay $200 for them to fix the issue that annoys me. But then again, why the hell am I having to do that on a brand new truck lol. 1st world problems i suppose haha
 
1 - 20 of 68 Posts
Top