Nissan Titan Forum banner
81 - 86 of 86 Posts

·
Registered
Joined
·
156 Posts
See another talk on this topic here:


We need to get some numbers of affected owners together to get some pressure on Nissan to fix the issue. It is ruining my enjoyment of an otherwise great truck, my fifth Titan.
 

·
Registered
Joined
·
1 Posts
I really like this truck but you are all correct. My 2021 Pro4x transmission is terrible and doing everything intermittently that was described in this thread. I hope Nissan wakes up and figures out a fix or this will be my last Nissan.
 

·
Registered
Joined
·
5 Posts
Another one here. I have a 21 Pro4x now with 5000 miles. I took it to the dealer yesterday for its first oil change and had a bullet list of things to cover with them:
  1. throttle response delay as everyone else is having here
  2. poor shifting when going slow - bouncing from 1/2/3 back to 2, etc.
Same thing echoed here - I won't jump into traffic unless its totally clear; the delay feels dangerous.

I told this to the service writer yesterday and here was his response:

You're dealing with 3 sensors to relay what your foot is inputting, to then reach the intake system which isn't a direct 1:1 relationship like a traditional cable to throttle body system. I have a new Rogue and it does the exact same thing.

Can the ECU be remapped to fix this?

No, its just the way all new vehicles are now.

You mean dangerous to drive? This makes zero sense.

Well....

Pretty disappointed. And I have terrible wind noise above 35 mph that they ignored yesterday too. He basically said since its all electronic with sensors "its just the way it is". We've had electronic / sensor vehicles for 30 years. Not acceptable and I want a better answer for 62k.
 

·
Registered
Joined
·
31 Posts
I guess i must be one of the lucky ones then... when the truck was new i had some hesitation from the gearbox especially when lowing down for a stop and then has to shift down to pull off again.. but after 7000 miles no more ... I have no issues now with the gearbox, it performs almost exactly as my GLE which have the "same" 9 speed box...
 

·
Registered
Joined
·
5 Posts
Edit: I just ordered the Banks PedalMonster. I’ll report back with my experience after installing that.

I spent a little time today reading up on this and given the popularity of these tuners, it’s a pretty common issue with the drive-by-wire systems. I don’t think it’s acceptable but more common than I thought.


Sent from my iPhone using Tapatalk
 
81 - 86 of 86 Posts
Top