Nissan Titan Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter · #1 ·
When I go over a speed bump or down to my favorite fishing spot(full of potholes) I get a thump from the font end....I don't think it is bottoming out, I seems more like it is overextending? I have stock suspension with different wheels and tires, but i did this when I had it all stock....I am sure this is common, just want to make sure.....
 

·
Registered
Joined
·
3,410 Posts
probably the upper arm hitting the coilbucket at full droop
 

·
Registered
Joined
·
635 Posts
I have the same thing. Mostly on the right side and at a little bit of speed. Was there w/ the orig susp, still there after the PRG leveling kit, and still there w/ the SAW's. Oh well, I live w/ it.
 

·
Registered
Joined
·
1,865 Posts
shave the friggen coil bucket... or get some uca's...
 

·
Registered
Joined
·
45 Posts
I have the same problem in the front somewhere but it ain't the buckets. No contact marks whatsoever and can't figure out what it is...already removed the swaybar with no luck. WTF? That's what I say.
 

·
Registered
Joined
·
292 Posts
I was just getting ready to start a post on this very thing. It's driving me nuts! I have 45,000 miles and it's only been doing it for the last 1,500 miles or so. I recently had an alignment done, and thought maybe that had something to do with it. What do you all think?
 

·
Registered
Joined
·
834 Posts
I'm at 2,500 miles and have had the same thing since day 1. I have to go over 2 speed bumps to get into my neighborhood so I am quite familiar with this sound & have learned to deal with it. If it is the upper arm hiting the coil bucket at full droop, then where do I look for the marks? Keep in mind I do not know what a coil bucket is - lol. Upper arm - I know that one.
 

·
Registered
Joined
·
1,301 Posts
07cajuntitan said:
If it is the upper arm hiting the coil bucket at full droop, then where do I look for the marks? Keep in mind I do not know what a coil bucket is - lol. Upper arm - I know that one.
Don't know if you're kidding or not about not knowing what the coil bucket is ... if not, see pic, coil bucket is where arrow is pointing ... you can see a small mark where stock UCA hit prior to adding on the badazz PRG upper arm you see in this pic
 

Attachments

·
Registered
Joined
·
323 Posts
Mine was doing that at one time. I could not see anything when I moved the suspension up and down in my garage. I ended up removing the strut and saw where there were gouges on top of the strut where it contacts the upper A-arm. New insulators solved the problem for me. Good luck.
 

·
Registered
Joined
·
45 Posts
I have a thud or popping sound on a right turn. Removed the swaybar and checked all the torques on my 6" pro comp lift - can't find anything. Any ideas?
 
1 - 12 of 12 Posts
Top