Nissan Titan Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I bought a 2010 Titan 4x4 SE at the end of November in 2010. A few days after purchasing it, I noticed a thumping/banging noise under the front end and could feel it in the floor board slightly when it happens. On the last trip to the dealership they replaced both front coils and it helped some but now it thumps more on the passenger side as opposed to the drivers side before. Like I said it helped replacing the coils, just annoying paying that much for a brand new vehicle and having the dealership give me the run around. Long story with dealership problems.

Any ideas what it could be??

I have read a lot of forums on here about various subjects and I have learned a lot on here. Was hoping someone might know how to take care of it. Thanks!
 

·
Registered
Joined
·
14,135 Posts
Is it just normal driving? Only when you take off from a stop? When your slowing down? If its when your taking off from a dead stop it could be your tranny mount is broke. Is the truck modified at all? Leveling kit? maybe the uca hitting the coil bucket when you hit bumps?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Sorry I did not specify. It is when I hit bumps. I have been reading a lot on the coil bucket contact threads, but I don't have any mods done yet so didn't know if that could be a possibility. I was going to crawl under there today to look at the the coil bucket but didn't get a chance. I'm wanting to put a 2" leveling kit on it but wanted to make sure this was taken care of first.

It doesn't happen during acceleration or deceleration just on any kind of bump on or off road. Even just like cracks in the road on occasion. The weird thing is it gets worse the colder it gets outside.
 
1 - 3 of 3 Posts
Top