Nissan Titan Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I bought a 2010 Titan 4x4 SE at the end of November in 2010. A few days after purchasing it, I noticed a thumping/banging noise under the front end and could feel it in the floor board slightly when it happens. On the last trip to the dealership they replaced both front coils and it helped some but now it thumps more on the passenger side as opposed to the drivers side before. Like I said it helped replacing the coils, just annoying paying that much for a brand new vehicle and having the dealership give me the run around. Long story with dealership problems.

It happens on and off-road when I hit a bump. Even just cracks in the road on occasion make the noise. It is all stock. I am wanting to put a 2" leveling kit on it but wanted to make sure I take care of this first. Since it is stock I didn't know if coil bucket contact could be the issue. I have read a lot of threads on here about but I'm no professional mechanic. It doesn't happen during acceleration or deceleration.

Any ideas what it could be??

I have read a lot of forums on here about various subjects and I have learned a lot on here. Was hoping someone might know how to take care of it. Thanks!
 

·
Registered
Joined
·
101 Posts
i have the same exact year truck, and everything! mine does the same thing yours does except mine does it when im pushing the brakes?


from what yours sounds like it could be the shocks....
 

·
Registered
Joined
·
7,353 Posts
i got a thumpin noise to under my rear seats and only happens when i turn the music up :teeth: JK

hope you get it resolved....
 

·
Registered
Joined
·
899 Posts
If its coil bucket contact, you can see a shiny dent in the coil bucket.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
i have the same exact year truck, and everything! mine does the same thing yours does except mine does it when im pushing the brakes?


from what yours sounds like it could be the shocks....
Did you get yours fixed? Did the noise stop?
 

·
Registered
Joined
·
101 Posts
Did you get yours fixed? Did the noise stop?


no havent had a chance to take it in yet, tried searching on here to see what it could be before i take it in and the dealership give me the run around
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
no havent had a chance to take it in yet, tried searching on here to see what it could be before i take it in and the dealership give me the run around
See I did the opposite of you and I have had to drive 2 hours roundtrip three times and still not fixed.

So what else could be directly affected that connects to the coils? Since the new coils helped it has to be something closely related to that area.
 

·
Registered
Joined
·
101 Posts
See I did the opposite of you and I have had to drive 2 hours roundtrip three times and still not fixed.

So what else could be directly affected that connects to the coils? Since the new coils helped it has to be something closely related to that area.



the way you explained it in the original post sounded like it could be your shocks bottoming out, does it only happen when you go over bumps or the same as mine when you apply the brakes?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #9
the way you explained it in the original post sounded like it could be your shocks bottoming out, does it only happen when you go over bumps or the same as mine when you apply the brakes?
It only happens when I hit bumps. I'm going to get under it tomorrow and see if I seen any bare metal.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #10
Nothing rubbing.. cleaned and greased the D bushings on the sway bar.. Found out through some other forums that it's just a design flaw in the oem shocks. A lot of other titans have the exact same problem. One guy he even said that he took a ride in a new 2011 with his dealer to see if it was just his truck or if it was something that was across the board, and he said that the new '11 had the clunk when it hit bumps with the manager driving. So, it looks like an upgrade is our only hope
 

·
Registered
Joined
·
101 Posts
Nothing rubbing.. cleaned and greased the D bushings on the sway bar.. Found out through some other forums that it's just a design flaw in the oem shocks. A lot of other titans have the exact same problem. One guy he even said that he took a ride in a new 2011 with his dealer to see if it was just his truck or if it was something that was across the board, and he said that the new '11 had the clunk when it hit bumps with the manager driving. So, it looks like an upgrade is our only hope


i figured it was the shocks
 

·
Registered
Joined
·
3,324 Posts
Yes I had a 2007 Se 4x4 and no clunks.

my new 2011 Pro4x has the clunking noise over taller speed bumps and if the road changes levels like drops 2" which I have read on here possibley the shocks topping out. also read its the ranchos but some have complained about the clunck w/o rancho's.
 

·
Registered
Joined
·
101 Posts
i just go slow over the bumps so i dont have to hear it, when i took it off road, i thought the truck was gonna explode!
 

·
Registered
Joined
·
3,324 Posts
i just go slow over the bumps so i dont have to hear it, when i took it off road, i thought the truck was gonna explode!
ya, I creep over speed bumps now like I have a lowered truck...ridiculous! My wife's G35 can handle the same speed bump faster with no issues but a 4x4 truck made for off roading acts like the bottom dropped out.
 
1 - 14 of 14 Posts
Top