Nissan Titan Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Have A 2004 Titan..........when Turning.........dashboard And Nav Display Warning Lights Come On.......door Ajar Warning Displays On Nav System And Dome Lights Come On...........its Been Back To The Dealer 5 Times Now.........last Fix......they Installed A "new Chip" In The Drivers Door........problems Went Away For 8 Months.......brake Problem Re Surfaced A Few Weeks Ago......along With The Lights.....are The Two Linked?
 

·
Registered
Joined
·
177 Posts
billgriffith said:
Have A 2004 Titan..........when Turning.........dashboard And Nav Display Warning Lights Come On.......door Ajar Warning Displays On Nav System And Dome Lights Come On...........its Been Back To The Dealer 5 Times Now.........last Fix......they Installed A "new Chip" In The Drivers Door........problems Went Away For 8 Months.......brake Problem Re Surfaced A Few Weeks Ago......along With The Lights.....are The Two Linked?
Sounds like you could have a door thats a little out of adjustment. Which door is showing up on the nav? Is it a crew cab or a king cab? You could have a wire pinched that only shows up when the cab flexes. If it is a four door truck and the nav shows a particular door try bringing in the door striker in a little to tighten up the door closing. If it is a two door you might have to bring the upper and lower strikers in on the rear door first before you adjust the front. It is hard to tell without knowing a lot more of the particulars of the problem and when it happens. Such as does it happen sitting still, or at slow speed turns on flat roads, or in slight off camber turns such as turns into a uphill driveway. Does it happen when you hit a bump, or a bump when turning? This sort of info helps.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Medium To Hard Left Turn Usually Causes The Problem.........this Brings On The Warning Lights.......brake, Engine,,,,,all Of Them At Different Times............its Like....all Of A Sudden........bad Info Is Being Sent To The Main Computer...........
 

·
Registered
Joined
·
177 Posts
billgriffith said:
Medium To Hard Left Turn Usually Causes The Problem.........this Brings On The Warning Lights.......brake, Engine,,,,,all Of Them At Different Times............its Like....all Of A Sudden........bad Info Is Being Sent To The Main Computer...........
If it is throwing the check engine and the brake warning light there should be a code stored stored in something or a past record in the CAN system of a fault in one of the controllers that had a communication problem. I've had this problem with the Altima and Quest, but not recently on the truck or suv, yet. Could be a pinched or rubbed CAN wire, or a loose connection at one of the terminals in a connector. It could take a little while to find.
 

·
Registered
Joined
·
1 Posts
I searched for symptons similar as to the ones I am going to reveal below:

Well, I don't know what my 2004 Titan SE's problem is but it has shut off on me multiple times while driving and the most current being in rush hour traffic two Wednesdays in a row in Atlanta, GA. The problem here is that when the truck dies, it really dies and I have virtually no control over things. Yep, this means that I have been doing a lot of prayer to not hit someone because I cannot stop and pray that no one hits me. It cranks about 1 minute or so after dying but starts quite sluggishly.

It has been to the dealer multiple time when it has occurred. the most recent occurrence was last Wednesday and the Wednesday before that in almost the same spot. Could it have been the heat that is causing this? The dealer where I get my servicing done and where I bought my last 3 Nissans cannot figure out what is going on. Last Friday, the fuel pump was replaced, I was called and went to pick it up later that evening but had to leave it once again because when I crunk it and was talking to one of the service personnel, it quit on me again and would not start.

Saturday, 9/2/07, I was called to pick it up but it wouldn't start and the mechanic that had been working on it could not get it to start and no codes appeared on his machine as has been the case each time. Is this thing possessed or what? This is quite frustrating and scary to risk my life when driving. Don't get me wrong, I am a Nissan fan thru and thru but I am skeptical to drive it if/when they do get it right.

Anyone have any solutions?
 

·
Registered
Joined
·
72 Posts
k4rich said:
I searched for symptons similar as to the ones I am going to reveal below:

Well, I don't know what my 2004 Titan SE's problem is but it has shut off on me multiple times while driving and the most current being in rush hour traffic two Wednesdays in a row in Atlanta, GA. The problem here is that when the truck dies, it really dies and I have virtually no control over things. Yep, this means that I have been doing a lot of prayer to not hit someone because I cannot stop and pray that no one hits me. It cranks about 1 minute or so after dying but starts quite sluggishly.

It has been to the dealer multiple time when it has occurred. the most recent occurrence was last Wednesday and the Wednesday before that in almost the same spot. Could it have been the heat that is causing this? The dealer where I get my servicing done and where I bought my last 3 Nissans cannot figure out what is going on. Last Friday, the fuel pump was replaced, I was called and went to pick it up later that evening but had to leave it once again because when I crunk it and was talking to one of the service personnel, it quit on me again and would not start.

Saturday, 9/2/07, I was called to pick it up but it wouldn't start and the mechanic that had been working on it could not get it to start and no codes appeared on his machine as has been the case each time. Is this thing possessed or what? This is quite frustrating and scary to risk my life when driving. Don't get me wrong, I am a Nissan fan thru and thru but I am skeptical to drive it if/when they do get it right.

Anyone have any solutions?
I know for a fact that the mass air flow sensor is extremely touchy on this truck. I cleaned my after market air filter awhile back and the filter felt like it was completely dry it got the tinyest bit of water on it and it started sputtering and shutting down wouldn't run. I would pull the mass airflow sensor let it dry out put it in and it would run fine for awhile till a tiny bit of water got on it and it would act up again I had to let it completely dry for a day till I could drive it again. Just thought I would share my experince and how sensitive the MAF can be, don't know if this will be useful or not.
 

·
Registered
Joined
·
2 Posts
I have a 2006 Titan and recently the battery keeps coming up dead. It's fairly new so I don't suspect the battery. I pulled the negative lead with the ignition key off and barely rubbed it along the negative battery post and can hear sparking. I suspect I have developed a current leak. Any suggestions?
 
1 - 7 of 7 Posts
Top