Nissan Titan Forum banner
1 - 20 of 24 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I have a 50 mi drive to work everyday with 45 miles of those miles on the highway with the cruise control on. (through very flat boring rural Illinois) For some reason the TPMS light pops on just after i hit 31 miles every day, each way. It stays on until i shut the truck off. I've checked the tire pressure and everything seems fine. it seems very odd that it would always come on after the exact same continuous mileage. Anybody ever heard of something like this? :huh:
 

·
Registered
Joined
·
14,163 Posts
lol i'm there too...its so weird. sometimes i think its cause i'm driving at high speeds for a long time ie prescott to phoenix, but other times i'm takin it easy and it still comes on. first time it did it i was with my friends in the middle of nowhere between yuma and phoenix scared the crap out of me.
 

·
Registered
Joined
·
88 Posts
Been doing it to me for years. Makes me wanna not use cruise control (or put a piece of tape over that TPMS light!)
 

·
Registered
Joined
·
70 Posts
My light always came on and off on and off because the weather is so crazy here were i live i guess but i just ended up taking them off and put a picture of my gf over the tpms light! haha so now i dont have to look at the stupid light
 

·
Premium Member
Joined
·
76,678 Posts
are you all sure you have the TPMS installed?

I have never had them to my surprise (figured this out when I swapped wheels)

My situation is that after about 45 minutes at highway speeds the light comes on and stays on until the truck is shut off.

My tire pressure has been and generally fine because i do regular checks and maintenance. sure can be bothersome.
 

·
Registered
Joined
·
2,006 Posts
You either have a bad sensor, or are running on the spare (no TPMS).
 

·
Registered
Joined
·
713 Posts
When I got my tires changed today at Discount Tire, they offered to "re-build" the TPMS inside the tire for something like $7.50 each tire. I said no, & he said, "Are you sure, because if you don't do it, it can cause the low pressure warning light on your dash to come on & stay on. All we do is replace a little rubber seal. How about this, I can offer to do it for 5 bucks each if you want to do it."

I went ahead & said OK, knowing maybe I was getting taken, but also knowing that since it's inside the tire it would be a pain to do later ... assuming it EVER had to be re-done.

Anyway ... Could this be ya'll's problem??
 

·
Registered
Joined
·
6,823 Posts
When I got my tires changed today at Discount Tire, they offered to "re-build" the TPMS inside the tire for something like $7.50 each tire. I said no, & he said, "Are you sure, because if you don't do it, it can cause the low pressure warning light on your dash to come on & stay on. All we do is replace a little rubber seal. How about this, I can offer to do it for 5 bucks each if you want to do it."

I went ahead & said OK, knowing maybe I was getting taken, but also knowing that since it's inside the tire it would be a pain to do later ... assuming it EVER had to be re-done.

Anyway ... Could this be ya'll's problem??
I read the same info on the TPMS rebuild kit and thought it was necessary when I bought new tires a few weeks ago. However, when I took the tires to a reputable tire place, he told me it was not necessary. Three weeks later, I have no leaks and no TPMS light, as it was over the last four years.
 

·
Registered
Joined
·
713 Posts
I read the same info on the TPMS rebuild kit and thought it was necessary when I bought new tires a few weeks ago. However, when I took the tires to a reputable tire place, he told me it was not necessary. Three weeks later, I have no leaks and no TPMS light, as it was over the last four years.
Might just be luck of the draw. I paid $20 to hopefully avoid the bad luck of the draw!
 

·
Registered
Joined
·
88 Posts
Even though my light comes on after 30 miles....the TPMS still works. If I have a low tire, it will light and start beeping.
 

·
Premium Member
Joined
·
2,005 Posts
Mines been on since I got it but has been flashing lately. Reason being the tire place didn't bother to actually do the TPMS when we had them do the tires even though they charged $10 per tire. Never going back there ever again.
 

·
Registered
Joined
·
201 Posts
I bought new tires for mine last year from Discount Tire and they replaced all the sensors in the tires. I thought it would fix the problem, but it did not. Went back up there and had them test all the sensors including the spare. Every one of them checked out just fine so I am guessing it is a bug in the receiver somewhere.:dunno:
 

·
Registered
Joined
·
1,224 Posts
Even though my light comes on after 30 miles....the TPMS still works. If I have a low tire, it will light and start beeping.
Yours beeps?
 

·
Registered
Joined
·
88 Posts
Yep..I always thought it never worked. But one day it started beeping at me, really loud. I don't remember the sequence, but I think it beeped three or four times then lit the light. When I got home I checked my tires and one of them was at 20PSI...so it actually worked!
 

·
Registered
Joined
·
1,224 Posts
Yep..I always thought it never worked. But one day it started beeping at me, really loud. I don't remember the sequence, but I think it beeped three or four times then lit the light. When I got home I checked my tires and one of them was at 20PSI...so it actually worked!
My light has come on twice in 3.5 years, both appropriately, but I don't think it ever beeped. Once I aired up, the light went back off after I drove a couple of miles.
 

·
Premium Member
Joined
·
17,446 Posts
Yours beeps?
Only the 04-05 "beeps".

04-05 Light with audible sound indicate low PSI. Light only indicate system malfunction

06-newer Light flashes for one minute at start up and stay lite indicate system malfunction. Light only indicate low PSI.
 

·
Registered
Joined
·
89 Posts
With all the owners here having this problem you'd think Nissan would have an answer. When I asked my Dealer to check it they noted my request on the workorder. The A-Hole mechanic came back and said "I couldn't get the light to come on". He merely turned the key on and it went off after the startup. Wanted to charge me to drive it around for an hour (using my gas). Didn't bother to check the system with their equipment.

Wonder if anyone has found an answer since this thread originally started. If not, I'll just use the "black electrical tape" solution. I check my tire pressures regularly and always look at them before I get in and drive. IMHO this system is for those who think maintenance is just filling the vehicle with gas.
 
1 - 20 of 24 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top