Nissan Titan Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hooked up my trailer brake controller, got a red light indicating the unit has power and knows when the brakes are on. But when I hook up the trailer I nothing else on the controller. Unit states it should give me the settings when trailer is connected. Do I need to wire up another fuse in the box in engine compartment? I did have the harness under the dash labeled "trailer brakes".
 

·
Super Moderator
Joined
·
161,956 Posts
You may need the relays.
 

·
Registered
Joined
·
70 Posts
You need a relay they usually have them in stock at the Nissan House its like ten bucks i think. Then you should be good to go.
 

·
Registered
Joined
·
2,006 Posts
The tow relays have absolutely nothing to do with the brake controller, just the lighting.

You have power and a ground. The only other connections are the wire from the brake pedal switch and the brake wire back to the trailer.
 

·
Registered
Joined
·
720 Posts
Since I already have the relays I have never checked to see if the harness is connected to the brake light switch or the towing system.

However, I have had a problem with corrosion or dirt getting into the connector and not having a good connection. I usually tap my trailer plug on the tongue before I plug in. When I do this, I never have a problem. If I don't do it, I have had lights not work until I did tap it clean.

You may need to chase the problem down with a volt meter and the assistance of another person.

The problem could be that the wiring on the trailer is not working right. You could check this with a 12v source and powering the brake wire at the trailer connector and listening to see if you hear the brakes engaging.
 
1 - 5 of 5 Posts
Top