Nissan Titan Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 · (Edited)
Just traded my dodge 1500 4.7l 2wd for a 4x4 Titan SE and I'm extremely happy with it so far. It has 215,000 mostly highway miles and drives perfect. On the downside, the transmission fluid is pretty burnt and I'm sure the transfer case isn't much better. I will be changing the transmission fluid tomarrow if everything goes right and the transfer case fluid today. What I need to know is where are the plugs on the transfer case. In the picture below, is the fill hole the left bolt and the drain hole the right bolt?

 

·
Registered
Joined
·
686 Posts
Your on the right track. Throw some Mobil 1 synthetic ATF in there and you'll be good to go. You can also use amsoil, Redline, or even the genuine Nissan stuff if you like. Just make sure you go with something synthetic.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
Did the transmission fluid yesterday and it shifts even better now. Just did the transfer case and now it won't go into 4hi. I can switch it in and it does the clicks and the thing beside it's mileage show all four wheels lit up but the 4x4 indicator won't come on. The 4lo indicator will come on when I put it in 4lo. The indicator light works because it still lights on start up; what could be my problem? I used just over 2 quarts of Nissan matic d.
 

·
Premium Member
Joined
·
141,094 Posts
4x4 indicator only comes on when it goes into low I think.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
Upon further inspection of the manual, I agree. The 4wd indiator is a warning indicator; if blinking or illuminated while the truck is running, there is a problem. I misunderstood the book in my haste to figure out what the problem was. Thanks for all your help guys.
 
1 - 6 of 6 Posts
Top