Nissan Titan Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Is This Happening To Anyone Else. For What Ever Reason My Truck Is Not Accelarating Like It Should. I Feel Like I Have A 4 Cylinder When I Step On The Gas. I Can Have Gas Pedal To The Floor And It Will Take Its Time To Pick Up Speed. Can Anyone Tell Me What This Might Be. Thank You
 

·
Premium Member
Joined
·
1,557 Posts
does your slip light come on? Looks like you got an 07, from what I can tell from the three people ive talked to with their 07 in person they love it. No slow reaction time for gassing.
 

·
Registered
Joined
·
1,586 Posts
plug the other 4 spark plug caps back in. haha no seriously, have you done anything to it since you got it? if not go straight back to the dealer
 

·
Registered
Joined
·
897 Posts
HMMM, 2 acceleration threads in the same day. Both with low count posters.

I'd say take it to the dealer and have them drive it.
 

·
Registered
Joined
·
83 Posts
I just got my 2007 a few days ago, and there is no problem with acceleration. I'm having a small electrical issue, but that is getting resolved today once I get off from work.
 

·
Registered
Joined
·
2,579 Posts
dirty air filter maybe?
 

·
Registered
Joined
·
1,194 Posts
one thing that is simple that you may be overlooking...have you put in any new floor mats?
I find if I don't put the Husky mats back in just right, it gets hung up under the pedal and when I press on the accelerator, it doesn't go down all the way preventing a slow acceleration.
 

·
Registered
Joined
·
1,573 Posts
Check your owners manual. The engine has built in safeguards to stop your engine from being damaged. It will limit rpms and other things. Contact your dealer.
 

·
Registered
Joined
·
1,586 Posts
phlydude said:
one thing that is simple that you may be overlooking...have you put in any new floor mats?
I find if I don't put the Husky mats back in just right, it gets hung up under the pedal and when I press on the accelerator, it doesn't go down all the way preventing a slow acceleration.
Ha i have actually done that on another truck. i took my dads floormats out of his f250 to clean them(thick aftermarket mats), and found out the accelerator went down another 1/4"! Must be a "Gas Saver Mod" lol
 

·
Registered
Joined
·
1,147 Posts
Maybe try resetting the ecu before taking it into the dealership.
 

·
Registered
Joined
·
2,955 Posts
I did something simliar with my Husky, but I put it over the top of the pedal, which prevented me from accelerating beyond 1/4 pedal. And of course, there was no risk of it getting stuck down. Now, that is a gas saver!
 

·
Registered
Joined
·
1,586 Posts
thoses stupid pedel covers people bolt onto the brake and gas to look cool use clamps, and ive seen the end of the bolt get stuck in the carpet at wot
 

·
Registered
Joined
·
96 Posts
Maybe a defective TPS (throttle position sensor) it does happen from time to time. Infiniti is notorious for this problem so I can imagine Nissan can have the same defective part.
 

·
Registered
Joined
·
30 Posts
that or what I said..

It is not a pedal issue. I have seen a handful of these. Defective sensor and or wiring
i just had this isssue today, so can someone explain to me on what i can look for to see if its the sensor and or wiring and where this sensor is? thanks
 

·
Banned
Joined
·
2,738 Posts
Electric throttle body. So something electrical, odds are a sensor.

easy test is tonight, disconnect the battery. This will reset the ECU. Then connect tomorrow before you head out..if still doing the same thing, dealership time.

Which I'm doing the reset tonight myself..gotta fix a few things before my buddy takes delievery.
 
1 - 20 of 20 Posts
Top