Nissan Titan Forum banner

181 - 198 of 198 Posts

·
Registered
Joined
·
647 Posts
Discussion Starter #181
I'm past the recommended 500 mile break in period and so far so good. I can feel the difference, it feels lighter at the take off. Does anyone know where the speedometer gets its reading from? It seems like my speed is not off, if it is, it is not by much. Does it get it from the speed sensor at the wheel hubs?

Sent from my SM-G930V using Tapatalk
 

·
Registered
Joined
·
162 Posts
Nice build. Just read through the whole thread. You dont happen to have the part number for that fuse, back in post #109 I think it was, do you?

Sent from my SM-N950U using Tapatalk
 

·
Registered
Joined
·
647 Posts
Discussion Starter #183
Nice build. Just read through the whole thread. You dont happen to have the part number for that fuse, back in post #109 I think it was, do you?

Sent from my SM-N950U using Tapatalk
No I don't know the part number. I never changed it out, the solder job has held up this whole time but the fuse is not hard to find. It is the big green one in your engine fuse panel. Thanks for reading.

Sent from my SM-G930V using Tapatalk
 

·
Registered
Joined
·
162 Posts
Yea I know where its located. I blew it a while back when I installed my remote start/alarm system. I just haven't replaced it yet due to not finding a part number. Thanks though.
No I don't know the part number. I never changed it out, the solder job has held up this whole time but the fuse is not hard to find. It is the big green one in your engine fuse panel. Thanks for reading.

Sent from my SM-G930V using Tapatalk
Sent from my SM-N950U using Tapatalk
 

·
Registered
Joined
·
647 Posts
Discussion Starter #185
Yea I know where its located. I blew it a while back when I installed my remote start/alarm system. I just haven't replaced it yet due to not finding a part number. Thanks though.

Sent from my SM-N950U using Tapatalk
Not 100% sure but I think this is it.


Sent from my SM-G930V using Tapatalk
 

·
Registered
Joined
·
647 Posts
Discussion Starter #187
Damn I looked everywhere online for that lol. That looks like it. Appreciate it man.

Sent from my SM-N950U using Tapatalk
No worries. Hope it works out.

Sent from my SM-G930V using Tapatalk
 

·
Registered
Joined
·
647 Posts
Discussion Starter #188
Another year has gone by and I'm still working on this list. I finally pulled the trigger and ordered the lift. I went with the 4" Rough Country. The lift came in today, still waiting on the rear Bilsteins, u-bolt flip kit and the driveshaft spacer. I already have the traction bars that I never got around to installing so I might start this weekend. Can't wait!


Sent from my SM-G973U using Tapatalk
 

·
Registered
Joined
·
9 Posts
Excited for the install! I like the height of your truck in the pic below, but fully support more lift. What exact setup is in the pic? What made you choose the RC 4 inch kit?

541480



I am also attaching a picture from @jonathanmolitor instagram. Its is the RC 4 inch lift, 20x12 wheels, 33 tires. It looks amazing. Good luck with the install.

541481
 

·
Registered
Joined
·
647 Posts
Discussion Starter #190
Excited for the install! I like the height of your truck in the pic below, but fully support more lift. What exact setup is in the pic? What made you choose the RC 4 inch kit?

View attachment 541480


I am also attaching a picture from @jonathanmolitor instagram. Its is the RC 4 inch lift, 20x12 wheels, 33 tires. It looks amazing. Good luck with the install.

View attachment 541481
In that pic I had the Swayaway coilovers cranked up a bit, probably 3". I removed them a while ago and installed Bilstein 5100s to the 2nd perch with a spacer when I thought the SAWs were bad but it turned out that it was my tires that were crap. I picked the RC 4" because it is the only 4" that I found and I didn't want to go 6".

Sent from my SM-G973U using Tapatalk
 

·
Registered
Joined
·
647 Posts
Discussion Starter #191
Forgot to add, that truck does look bad a$$.

Sent from my SM-G973U using Tapatalk
 

·
Registered
Joined
·
162 Posts
What size tires you going to run with the 4" lift? I've debated dropping mine down to 4" but I'm on 35's. Not sure if I'd stick with them or go 33's.

Sent from my SM-N950U using Tapatalk
 

·
Registered
Joined
·
647 Posts
Discussion Starter #193
I have 35s on now. No plans on going any bigger at this time.

Sent from my SM-G973U using Tapatalk
 

·
Registered
Joined
·
647 Posts
Discussion Starter #194
Finally done. I pieced meal this install over a week and it took me about 40 hrs. Haha Did it all myself in my drive way. It always takes me about double the time but it gets done right... eventually. Pretty happy with the results. I like the stance and for whatever reason my tires look bigger to me.

Still waiting on PRG to send me the rear Bilsteins, U-bolt flip kit and the driveshaft spacer. Sorry for the bad pic, didn't notice until later. Went and got an alignment and gave her a much needed bath. Will have better pics next time.

Tomorrow I plan to install some Sylvania LED lights that I got for Xmas last year. Haha now that I have a little more room I will probably install them below the bumper. Also plan on installing my traction bars that I bought 2.55 years ago and never got around to.


Sent from my SM-G973U using Tapatalk
 

·
Registered
Joined
·
9 Posts
That's perfect! It looks like a completely different truck. The lift compliments the wheels and tires more than your previous setup. Congrats on the install.

How were your ball joints? Any problems removing lower control arm camber bolts? I've got my RC 4" and front 5100's ready to go on :D
541698
 

·
Registered
Joined
·
647 Posts
Discussion Starter #196
That's perfect! It looks like a completely different truck. The lift compliments the wheels and tires more than your previous setup. Congrats on the install.

How were your ball joints? Any problems removing lower control arm camber bolts? I've got my RC 4" and front 5100's ready to go on :D
View attachment 541698
Thanks! I'm pretty happy with how it turned out. I had no issues with the ball joints or the lower control arms. I had to be liberal with the PB Blaster on the camber bolts and all of the cross member bolts. Make sure you use a 6 point socket and not a 12 point to break the torque.

Sent from my SM-G973U using Tapatalk
 

·
Registered
Joined
·
647 Posts
Discussion Starter #197 (Edited)
Got the lights on and they are bright!


Sent from my SM-G973U using Tapatalk
 

·
Registered
Joined
·
647 Posts
Discussion Starter #198
Just added the Rough Country traction bars.


Sent from my SM-G973U using Tapatalk
 
181 - 198 of 198 Posts
Top