Nissan Titan Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
899 Posts
Discussion Starter #1
I finally got my Uprev tune on the truck, but my cruise light does not blink to tell me what tune I have selected. I know the tune is working because I got the Valet tune with a 2500 RPM rev limiter and I tried it out. The truck runs great, the only problem is the cruise light. I guess it's not that big of a deal. Just wondering if anyone elses did this.
 

·
Registered
Joined
·
419 Posts
Using the Cruise Control Buttons...
-Hold the set/coast toggle down
-Press "Cancel" once for map 1, twice for map 2, etc...
-Then release the set/coast toggle.
-When you release the toggle, the cruise "SET" light on the dash will blink once for map 1, twice for map 2, etc...

Should work exactly as above......the 2004 Titan is only good for 3 maps the rest can hold 5
 
  • Like
Reactions: Pro4Jackster

·
Registered
Joined
·
899 Posts
Discussion Starter #4
It switches maps. But the set light does not blink to verify that I have changed maps.
 

·
Registered
Joined
·
8,459 Posts
That's strange... You should see the set light flash on the right side of the gauge cluster as many times as what map your in.
 
  • Like
Reactions: Pro4Jackster

·
Registered
Joined
·
899 Posts
Discussion Starter #6
When I ordered it, Uprev could not support my ECU yet. I had to do the ROM Dump and send him the file, then they created my tune. Maybe they left something out. I'll let them know when I do my first E-tune. I'm going to wait until I get the DTLTs and Bpipes installed. Thanks.
 

·
Registered
Joined
·
8,459 Posts
As long as you can change map's you should be fine. Maybe the LED is burned out in the cluster?
 
  • Like
Reactions: Pro4Jackster

·
Registered
Joined
·
1,997 Posts
Congrats on the new toy Jackie! So does your CC still work?
 
  • Like
Reactions: Pro4Jackster

·
Registered
Joined
·
899 Posts
Discussion Starter #9
Congrats on the new toy Jackie! So does your CC still work?
My Credit Card? Yeah it still works. It's showing a lot of wear and smokes every time I swipe it. It won't be long until it bursts into flames...this site is going to break me. Ha Ha.
 

·
Registered
Joined
·
126 Posts
I think he means cruise control..
 

·
Registered
Joined
·
899 Posts
Discussion Starter #11
Yeah. I try to be funny, but my dry sarcasm doesn't work very well typed. I need to give it up.

I just went out and tried the cruise control and it works fine. But there is no Set light on the right side of my cluster. Only the written words "cruise" and "set" directly below my odometer. If there should be another light, then that is my problem. I have a light out.
 

·
Registered
Joined
·
8,459 Posts
Yea, there's a "SET" light on the right side of the cluster, half way down. It light's up red.
 
  • Like
Reactions: Pro4Jackster
1 - 12 of 12 Posts
Top