Nissan Titan Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
647 Posts
Discussion Starter · #1 ·
I had an interesting set of warning lights come on today. I was on a dry road going about 10 mph and I floored it to hear the dual exhaust (truck was warmed up). I let off around 45mph and noticed that the VDC/SLIP/ABS lights were on. I pulled over to a parking lot, shut it down, started up again and the lights were still on. I couldn't find anything in the manual about that combination of light. I shut it off and started up again. After turning around in the parking lot, the lights turned off and never came back on again all day. Anyone else ever have this happen? Was this just a software glitch???
 

·
Registered
Joined
·
2,832 Posts
I have experienced this, but with BRAKE, VDC OFF and SLIP. ABS light never came on, but I figured that was covered by the VDC OFF light Looked it up in the Owner's Manual and it wasn't listed with all 3 lights. The closest was having SLIP and VDC OFF both on, and it said to go to the dealer for service. I watched it for a few days and noticed that the BRAKE light would usually come on a second before the others. I checked my brake fluid and it was at the minimum. I filled it back up and the lights haven't come on since. My guess is that if the brake fluid gets too low, VDC cannot function properly.
 

·
Banned
Joined
·
791 Posts
HavockWK said:
I have experienced this, but with BRAKE, VDC OFF and SLIP. ABS light never came on, but I figured that was covered by the VDC OFF light Looked it up in the Owner's Manual and it wasn't listed with all 3 lights. The closest was having SLIP and VDC OFF both on, and it said to go to the dealer for service. I watched it for a few days and noticed that the BRAKE light would usually come on a second before the others. I checked my brake fluid and it was at the minimum. I filled it back up and the lights haven't come on since. My guess is that if the brake fluid gets too low, VDC cannot function properly.
Also if the ABS, Slip, and VDC are all on, perhaps a bad ABS sensor since it would affect all systems.

I would definitely have this checked out by service as my '96 Camaro POS had an ABS sensor fail which took out the ABS system and my power brakes. I was trying to stop on a snowy slick surface with no power boost on my brakes. I thought I was a goner. Surprisingly, while my ABS sensor was failing, it was still within GM's specs. as 'alright' so the service center couldn't replace under warranty even if they did agree it was malfunctioning. I guess GM has no sense of loyality to the customer's safety, but they want you to be loyal to them.

Good luck and have a good one.
 

·
Registered
Joined
·
3 Posts
I had the same thing happen before I got rid of my Titan, cause the problems kept going up, and the dealers around here had no answers. This is what Nissan did, turned off the truck, didn't work, then they reprogramed the computer, and the lights went off....they go, Problem Fixed! Go figure......
 

·
Registered
Joined
·
156 Posts
Similar problem here this weekend - "Diff Lock" started flickering, then in went off and the "Slip' and ABS" lights came on and stayed on until I turned the ignition off again. Appointment for tomorrow with the dealer.

BTW, also found an antifreeze leak from below the radiator, and a LOOSE SCREW on the right side of the sway bar!!!!
 

·
Registered
Joined
·
32 Posts
i just had my lights come on and ran the consult code.. it came back c1106 which is a Rear Driver side ABS Sensor
 

·
Registered
Joined
·
411 Posts
I had this happen right after I bought mine last spring, all three lights came on and stayed on. It was diagnosed as a front pressure sensor which was replaced and I never had the problem again.
 

·
Registered
Joined
·
55 Posts
I had a similar problem after my last visit t the dealer fr the brakes. My VDC/Slip/Brake lights came on. When I tok it back they said it was from low brake fluid that wasnt topped off when they fixed the brakes for the 3rd time. It doesnt come on anymore but who knows if its right. I am now up to seven visits for the brakes and filled a lemon-law suit last week. I still have t go back at least once more for the brakes, they still arent right...frnt end is shaking again.
 

·
Registered
Joined
·
6,373 Posts
I had the same problem as you, I also checked my brake fluid and it was at min. so i filled and have had no problem since.
If your fluid level was at min, then you need to check the brakes, unless someone has just worked on the system.
Low fluid level = thin brake pads.
 
1 - 10 of 10 Posts
Top