Nissan Titan Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1 (Edited)
Yes, I realize there are dozens of threads on this forum and others around Volant fitment issues. I have done a lot of searching and could not find a thread that resolved the same problem I am having. Please, if you have seen this issue and can give me a quick tip or send me to a link that resolves my issue, I would greatly appreciate it.

I have a 2004 Titan LE. As part of a group buy, I bought a Volant CAI back in March 2005. The CAI has been sitting in my garage brand new in the box since I received it... I have no good excuse on why! :huh:

This weekend, I finally got off my duff and attempted the install. I am having the issue where the rear stock mounting bracket (back by the brake lines), which does not appear to be used with the Volant system, is interfering with alignment of the Volant CAI to the fender well.

I thought I might be able to remove the interfering bracket (as many others tried before me), but it is integrated into a larger bracket that appears to hold other parts in place.

I sent an e-mail to Volant, but it's a Holiday weekend and my guess is they won't get it until Monday. I would love to get this baby installed this weekend! Thanks for any help!
 

·
Registered
Joined
·
11 Posts
Discussion Starter #2 (Edited)
Let me clarify my post above: I've found some other posts with a similar issue, but no one really outlined a solution other then "I jammed it in there," or "I bent or removed the stock bracket." That hardly seems like the right solution for a quality name brand kit like this...
 
1 - 2 of 2 Posts
Top