Nissan Titan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,035 Posts
Discussion Starter #1
Hey everyone,
As some of you might know I picked up my Titan Tuesday evening and I am loving it more and more as the minutes go by. It is just way too awesome of a truck! I was wondering if anyone else has heard an odd air pump/valve noise coming from the front passenger A/C area?? I only hear it when the A/C is turned on. So, like when I push in the A/C button and turn the cold air off and its just blowing lukewarm air, it doesn't do it. Only when the A/C is turned on blowing cold air....Just wondering if it was something relativel common and nothing to worry about. Thanks for any input :)

BTW I will be posting pictures of the truck later 2nite, so standby!
 

·
Registered
Joined
·
295 Posts
I have noticed this on the last 4 vehicles I have owned and now also on the Titan. I think it was something to do with the Eco-Friendly A/C systems. Another gift from the Eco-wacks. :rolleyes:
 

·
Registered
Joined
·
105 Posts
there was a previous thread about the same thing....it turns out everyone has the same issue and its normal actuator/vacuum (sp?) noise
 

·
Premium Member
Joined
·
2,763 Posts
I heard the same thing on my recent trip. I turned the A/C off and the sound went away which leads me to believe I am going to have to get used to it for the summer months.
 

·
Registered
Joined
·
1,062 Posts
All the trucks make this sound. It is coming from the AC Expansion/Pruge Valve that is located inside of the Evaporator Case. It cycles on and off with the AC Compressor, when the clutch engages (which you can hear) thats when you will hear the sound. Nissan has been and is curently working on a fix for this! Although all of the trucks make this Sound, It is NOT Normal! It shouldnt be to long before they come up with one. Just thought I would that you all know. :)
 
1 - 5 of 5 Posts
Top