Nissan Titan Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
893 Posts
Discussion Starter #1
I just wanted to know what are some signs of a bad hub bearing. Right now I dont have a jack to lift it, but when I drive at high speeds it makes a weird metallic noise ONLY at high soeeds. Also when I brake I feel the drivers side wheel slide as if something shifts slightly. Last thing is when i accelerate I feel a thump on the dash. That is probably another problem but I just need some help.


The truck is a 05 CC 2wd
 

·
Registered
Joined
·
6,373 Posts
Typically some abnormal, or even high heat felt at the hub. grinding noise while moving, listen with window down. Don't wait to repair!
 
  • Like
Reactions: I.E. Titan

·
Registered
Joined
·
53 Posts
Bad bearing will make a whirring noise. if its the drivers side listen when you drive down the road and turn right if it gets worse then its probably the bearing. best way jack it up hold bottom and top of tire and move it of have someone look at it. good luck have it checked soon if its loose it could go flying off.
 

·
Registered
Joined
·
83 Posts
Mine was constant whirring noise at any speed. I did not experience wheel slipping though. Wheel hub should be loose once you can get your tires off. It was the driver side but I went ahead and had both sides replaced for $280 parts + $150 labor. Was going to do it myself but couldn't get the axle bolt off.
 
  • Like
Reactions: I.E. Titan

·
Registered
Joined
·
893 Posts
Discussion Starter #5
Thanks guys. My uncle took the truck into his shop tonight hopefully ill know in the morning
 

·
Registered
Joined
·
14,140 Posts
its an easy fix, do it yourself or at a shop you know someone. if its a difficult bolt, use an impact.
 

·
Registered
Joined
·
878 Posts
I warped a bearing once. You could feel it at the steering wheel. like a lub lub lub noise that got faster the faster i went. I drove it till it froze. almost wrecked me on the freeway... front left wheel just locked up while i was going 70 and talking on my phone...
 

·
Registered
Joined
·
893 Posts
Discussion Starter #8
I just talked to my uncle and he told me it is a bad bearing. It sucks but now I'm wondering where to buy a hub assembly for a 2005 4x2. Or a parts number would be great. I remember seeing them for about 130. Can anyone help me with this
 

·
Registered
Joined
·
893 Posts
Discussion Starter #10
Thanks man I really appreciate it
 

·
Premium Member
Joined
·
141,094 Posts
Broken brake pad.
 

·
Registered
Joined
·
83 Posts

·
Registered
Joined
·
893 Posts
Discussion Starter #13 (Edited)
I just got the truck back and they replaced the hub assm. but when i got on the highway it continued making the wiring sound at high speeds only*over 60mph*. Took my uncle with me and he heard it but he is puzzled to what the sound could be. Anyone have any ideas of have had this same problem? i dont want to be f**ked over here.


Just tAlked to a friend and he said that it could have been from the weights on the wheels when I got them balanced recently. Could that be it?
 

·
Registered
Joined
·
4,256 Posts
I just got the truck back and they replaced the hub assm. but when i got on the highway it continued making the wiring sound at high speeds only*over 60mph*. Took my uncle with me and he heard it but he is puzzled to what the sound could be. Anyone have any ideas of have had this same problem? i dont want to be f**ked over here.


Just tAlked to a friend and he said that it could have been from the weights on the wheels when I got them balanced recently. Could that be it?
Greg told me this as well, just go look at them, see if they are loose/move at all.
 
1 - 14 of 14 Posts
Top