Nissan Titan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
787 Posts
Discussion Starter #1
So I had my deaver c-30 pack and rear bilsteins installed and on the way back home from the shop I noticed the drive shaft vibration was noticeably worse. At speeds around 30 I noticed alot of vibration in the steering wheel as well. When I would slam on the gas from a stop the vibration would be so bad it almost sounds like a grinding noise. I started noticing vibration in the drive shaft a little bit after I put on the cst 4" spindles, so it's not new, just worse. My question is, why is this happening, and is it something that can be fixed, or could the vibration be coming from something else? The mechanic that put the parts on told me that lifting titans in the rear is going to give it driveshaft vibration, but this is just unbearable.
 

·
Registered
Joined
·
787 Posts
Discussion Starter #3
Yea I knew he hadta be full of ****. My first titan was lifted and I never had any problems either, so I'm stumped on what to do about this.
 

·
Registered
Joined
·
16,113 Posts
if your 2wd you need to get a carrier bearing drop bracket. and your an 08 right? i think they have that issue. my 07 has a procomp kit, and im not having any vibrations
 

·
Registered
Joined
·
787 Posts
Discussion Starter #5
yea im an 08, but i was to understand that a carrier bearing drop bracket was only needed with 4+ inches of lift in the rear, and the deaver pack only gives 2.5
 

·
Registered
Joined
·
16,113 Posts
well if your truck is still under warranty i would take it to the dealer and have them check in to it. my guess is that your driveshaft needs to be balanced. but your deavers shouldnt have caused that. sorry man, wish i could help you more.
 

·
Registered
Joined
·
3,655 Posts

·
Registered
Joined
·
10,960 Posts
its the carrier bearing. or you need the drive shaft spacer. maybe he didn't tighten every thing down.
 
1 - 8 of 8 Posts
Top