Nissan Titan Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
265 Posts
Discussion Starter · #1 ·
I've searched with no luck... I think I blew a fuse for my back seat 12v Outlet on my 06 CC LE.. Please help, is it in the engine fuse box or the cab, and what is it labeled as? I can't seem to find it?!:bangit:
 

·
Registered
Joined
·
2,216 Posts
I've searched with no luck... I think I blew a fuse for my back seat 12v Outlet on my 06 CC LE.. Please help, is it in the engine fuse box or the cab, and what is it labeled as? I can't seem to find it?!:bangit:
It's in the cab near the glove compartment. It is labeled as "Power Socket Console." You will need a 15A low profile fuse (smaller than the mini fuse). The O'Reilly's near me doesn't carry them but Autozone does.

When mine blew, I couldn't tell by looking at the factory fuse because it was not transparent. The Bussmann fuses I replaced them with are transparent so I can see when they blow. I don't think they make the LED fuse in the low profile variety, but I could be wrong. With those, the LED comes on when the fuse is blown.
 

·
Registered
Joined
·
6,390 Posts
Mini-ATC can fit, but Low Profile is much better looking of course. Mini-ATC will stick out further. Low Profile is still uncommon, I've only learned of them from the Titan...
 

·
Registered
Joined
·
265 Posts
Discussion Starter · #4 ·
It's in the cab near the glove compartment. It is labeled as "Power Socket Console." You will need a 15A low profile fuse (smaller than the mini fuse). The O'Reilly's near me doesn't carry them but Autozone does.

When mine blew, I couldn't tell by looking at the factory fuse because it was not transparent. The Bussmann fuses I replaced them with are transparent so I can see when they blow. I don't think they make the LED fuse in the low profile variety, but I could be wrong. With those, the LED comes on when the fuse is blown.
Dang.. I thought so.. The fuse is good.. I even tried to replace it anyways, no luck.. I've tried my cell phone charger in the other outlets and it works fine, so its the outlet for sure... Any ideas?
 

·
Registered
Joined
·
878 Posts
Dang.. I thought so.. The fuse is good.. I even tried to replace it anyways, no luck.. I've tried my cell phone charger in the other outlets and it works fine, so its the outlet for sure... Any ideas?
i replace the one on the right on the dash. the previous owner had something get stuck in it an his buddy went at the inside of it with some needle nose pliers and bent it all up. i plugged the new one i got from the dealership in and it doesnt work either and all my fuses are fine. im confused also. i hope this thread gets some answers.
 
1 - 11 of 11 Posts
Top