Nissan Titan Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
The brake light came on. Not abs, just the red "brake" light. The Ebrake is disengaged and I pulled the wheels and have plenty of thickness on the pads.
Any ideas?
 

·
Registered
Joined
·
1,492 Posts
check your fluid
 

·
Registered
Joined
·
5,541 Posts
what USN said... i've had my light come on before too... checked the brake fluid level and it was below the low line.. topped off, light disappeared... good to go :hat:
 

·
Registered
Joined
·
111 Posts
Just had the problem... change pads and add some fluid. BINGO!
 

·
Registered
Joined
·
48 Posts
Sorry to re-open this thread, but now I'm having the issue. Fluid level fine, new front rotors and pads installed this past weekend, same result. It's sporadic, not consistent light on all the time. Sometimes its off, other times it can't decide to stay lit. I can give the emergency brake pedal a like kick-push upward the light would blink off, could that be a sign of the emergency brake level sensor?
 

·
Registered
Joined
·
113 Posts
this just happened to me the brake fluid level was WaY below low, What would cause this too happen?? could my pads be that worn that it would use alot of fluid to clamp the rotor? or do I have a leak somewhere???
 

·
Premium Member
Joined
·
17,244 Posts
this just happened to me the brake fluid level was WaY below low, What would cause this too happen?? could my pads be that worn that it would use alot of fluid to clamp the rotor? or do I have a leak somewhere???
Could be either worn pads or a leak. The pistons have to be pushed farther out of the caliper when the pads are worn, which creates a greater volume inside the caliper to hold fluid, thus reducing the level in the master cylinder.
 
1 - 9 of 9 Posts
Top