Nissan Titan Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
637 Posts
Discussion Starter #1
I searched and didn't find any clear info on the topic so I thought I'd ask...

My squirters are not working - Both quit at the same time.

The tank got low and the light came on so I filled it up. After filling, the pump humms but produces no money shot. So I let the fluid sit in there for a few days hoping it might dissolve or soften what ever was in there and still no blow.

Any suggestions?
 

·
Registered
Joined
·
501 Posts
hate it when the squirter malfunctions.....
 

·
Registered
Joined
·
2,311 Posts
Also interested...my passenger side is not working either. It slowly got less and less pressure and then just fizzled out and no longer squirts.

At least I still have one good squirter.
 

·
Registered
Joined
·
2,311 Posts
check the line for holes!!! have one guy trying to make it squirt then have the other looking for leaks
Problem is, I can't see the line, it looks like you have to remove the cowl to get to it. And I still don't know how to remove my cowl without breaking the clips.
 

·
Registered
Joined
·
152 Posts
I had that happen to me, I took the hose out and some how a small pebble had made its way through it and got stuck so check your hose
 

·
Registered
Joined
·
2,311 Posts
I had that happen to me, I took the hose out and some how a small pebble had made its way through it and got stuck so check your hose
So did you have to take the cowl off to do it?
 

·
Premium Member
Joined
·
37,152 Posts

·
Registered
Joined
·
2,311 Posts

·
Premium Member
Joined
·
37,152 Posts
Hahaha...I'm paranoid that I'm gonna break the damn clamps lol
What's the worst thing that happens, you break one or two and have to spend $1 at the dealership for some new ones? Just go slow and use needlenose pliers.
 

·
Registered
Joined
·
2,311 Posts
What's the worst thing that happens, you break one or two and have to spend $1 at the dealership for some new ones? Just go slow and use needlenose pliers.
You make a valid point.
 

·
Registered
Joined
·
1,003 Posts
Yea I had this happen also. I had to take the squirter out and blow the junk out. The cowl is pretty simple to get off bro. Just the plastic clips. If I can do it you can.
 

·
Registered
Joined
·
686 Posts
What's the worst thing that happens, you break one or two and have to spend $1 at the dealership for some new ones? Just go slow and use needlenose pliers.
Or even go to the dealer first and grab a few of them so you have them on hand when you do the job, then you really have nothing to worry about!
 

·
Registered
Joined
·
637 Posts
Discussion Starter #14
Got mine fixed. Turns out SafeLite Auto Glass left them disconnected after they put my windshield in. I called and had them come fix it.
 
1 - 14 of 14 Posts
Top