Nissan Titan Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
If anyone has upgraded there Fosgate system or has parts to sell need rear speaker amp, located to the right of the steering column, TIA
 

·
Registered
Joined
·
4,808 Posts
3dad said:
If anyone has upgraded there Fosgate system or has parts to sell need rear speaker amp, located to the right of the steering column, TIA
If you have the Fosgate system its only one amp that powers all the speakers.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #3 ·
The head unit shows " the head phone " icon on the display,, the front speakers work, there is a plug hanging from the area where the amp is "supposed" to be???? its an 06 King cab
 

·
Registered
Joined
·
940 Posts
3dad said:
The head unit shows " the head phone " icon on the display,, the front speakers work, there is a plug hanging from the area where the amp is "supposed" to be???? its an 06 King cab
Check your owners manual. In my crewcab, that means the the rear speakers are off and the wireless headphones are one. There is a button on the face of the stereo (also has the headphone icon on it) that toggles this function. I think the plug you are seeing is the sat radio harness. There is only one amp (on the firewall) for the Fosgate system.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #5 ·
Looked under the dash and the am is gone, the Fosgate does not have a button for the rear spearkers or headphones that I saw. Thanks for the help though, I bought this truck at a repo sale so its had a story with it , thanks again
 

·
Registered
Joined
·
4,808 Posts
3dad said:
Looked under the dash and the am is gone, the Fosgate does not have a button for the rear spearkers or headphones that I saw. Thanks for the help though, I bought this truck at a repo sale so its had a story with it , thanks again
Thats weird... are you sure it has the Rockford package with it? Look under the drivers seat and see if there is a 8" subwoofer under here. Its a big black box. I dont think it could work at all without the Rockford amp unless its not a real Rockford system and someone changed the faceplate.
 

·
Registered
Joined
·
940 Posts
Exactly what model is your truck? King or crew cab? XE, SE, or LE? Like t22a80 said, look for the sub under the driver's seat. The Rockford amp is very hard to remove, and if your front speakers are working the amp must still be there. Do you have any pics of the face plate? Here is a pic of my RF head unit, you can see the button I'm talking about just to the right of the aux button.
 

Attachments

·
Premium Member
Joined
·
17,244 Posts
The amp is located on the firewall, way up under the driver side dash. You have to lay on your back on the floor and look up at the firewall to see the amp.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #10 ·
There are 2 boxes to the right of the steering column,, one is for the EBX or engine controller the other? the amp is supposedly sandwiched in between,, nothings there. TIA
 

·
Registered
Joined
·
4,808 Posts
Someone on here had a pic of what the factory amp looks like. If I remember I'll take a pic tomorrow if nobody else has one.
 

·
Registered
Joined
·
4,808 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #14 ·
Well now its back to square one, its on the cowl, its the rear box,, I quess I take out the radio and look to see it all the plugs are in it. thanks TS
 

·
Registered
Joined
·
4,808 Posts
That pic of the amp is just to give you an example of how small it is and why it doesnt sound as good as an aftermarket one does.

If you look up under the dash near the steering column then you should see 2 brackets with that amp or something similar to it up there. If you just see 2 brackets and nothing like that then you dont have the Rockford package.
 
1 - 15 of 15 Posts
Top