Nissan Titan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
270 Posts
Discussion Starter #1
WTB: Climate Control Cluster for my 06 LE CC.. If you read through some of my threads you'll see that I am having problems getting heat on my drivers side.. I've already replaced the vent door actuator for the drivers side.. No luck. So I'm willing to give the climate control a try..
Please let me know if you have one for sale.
Thanks
 

·
Registered
Joined
·
117 Posts
WTB: Climate Control Cluster for my 06 LE CC.. If you read through some of my threads you'll see that I am having problems getting heat on my drivers side.. I've already replaced the vent door actuator for the drivers side.. No luck. So I'm willing to give the climate control a try..
Please let me know if you have one for sale.
Thanks
Its not the control head. I would do some serious diagnosing before I spent money on a part that cost over $350 from NISSAN. Theres about 5 different acuators under the dash and I've sold probably every one of them at one point in time. Including replacing one on my personal truck. It might not be the actuator though, what about the linkage?
 

·
Registered
Joined
·
270 Posts
Discussion Starter #3
Its not the control head. I would do some serious diagnosing before I spent money on a part that cost over $350 from NISSAN. Theres about 5 different acuators under the dash and I've sold probably every one of them at one point in time. Including replacing one on my personal truck. It might not be the actuator though, what about the linkage?
Dude, thats a risk that I'm almost willing to take at this point! It sucks when its 25 degrees and your "heater" is blowing cold air in your face or not defrosting your windshield.. I've had the vent door actuator replaced with the linkage that controls the vent door for the drivers side with no luck.. Its the one on top of the heater box. I had it done at a shop as it was a little too deep in the dash for my comfort with the air bag(s), etc.. There are several actuators like you said, but there is/should be only one for the drivers side cold/heat adjustment, the rest are for foot, dash, and defrost levels. When I had the glove box out and could see the actuator it is actuating, but not fully I assume because the drivers side never gets hot, once the truck warms up and the system is on recirculate, it blows warm air at best.. Its almost like its not circulating through the heater box.. I thought there may be a slim chance that the controls were not fully operating the actuator to direct the air through the heater box... So, I don't know where else to go at this point. I've posted this issue several times on the forum with no luck, its been over a year now.
 

·
Registered
Joined
·
8 Posts
Can you describe what your cluster lookls like? I bought one to replace mine and it wasnt the correct one. I was gonna try and custom fit it, but the hookups in the back are different than mine. The one I have says its for a 2008 Titan. I dont know if it works, but its in great condition. It did come from a junkyard, but they had excellant reviews (ebay) so i feel it is still operational. I only paid $35.00 for it..so if it will work for you..then you can have it for what i paid, plus whatever shipping is from zip 28804. I have no idea how to post pics here, but can email or text you pics of it..Just let me know.
 

·
Registered
Joined
·
270 Posts
Discussion Starter #5
Can you describe what your cluster lookls like? I bought one to replace mine and it wasnt the correct one. I was gonna try and custom fit it, but the hookups in the back are different than mine. The one I have says its for a 2008 Titan. I dont know if it works, but its in great condition. It did come from a junkyard, but they had excellant reviews (ebay) so i feel it is still operational. I only paid $35.00 for it..so if it will work for you..then you can have it for what i paid, plus whatever shipping is from zip 28804. I have no idea how to post pics here, but can email or text you pics of it..Just let me know.
Its the dual climate control head. Mine looks just like the attached picture. Let me know if thats the one you have. If so, I'll buy it.
Thanks
 

Attachments

·
Registered
Joined
·
270 Posts
Discussion Starter #6
WTB: Climate Control Cluster for my 06 LE CC.. If you read through some of my threads you'll see that I am having problems getting heat on my drivers side.. I've already replaced the vent door actuator for the drivers side.. No luck. So I'm willing to give the climate control a try..
Please let me know if you have one for sale.
Thanks
:bump::bump::bump:
 

·
Registered
Joined
·
13 Posts
Did you guys ever solve the climate control problem? I also have a problem with my 2004 SE non-dual, non-auto zone, controller. My vent selector knob intermittently doesn't change to the correct vent. It mostly stays on defrost or low/foot area. Never wants to change to high/vents. Any ideas? Change the module? Thanks.
 

·
Registered
Joined
·
270 Posts
Discussion Starter #8
Did you guys ever solve the climate control problem? I also have a problem with my 2004 SE non-dual, non-auto zone, controller. My vent selector knob intermittently doesn't change to the correct vent. It mostly stays on defrost or low/foot area. Never wants to change to high/vents. Any ideas? Change the module? Thanks.
Unfortunately not... I bought a module/cluster off eBay with no luck. With the radio bezel out, I changed from cold to hot and could see the actuator moving on top of the heater box for the driver's side, not sure if the full cycle or not, but the driver's side remains luke warm at best.. This is going to SUCK, AGAIN, come winter.
 
1 - 8 of 8 Posts
Top